Bug 1313549 - Volumes in 3.1 don't mount git
Volumes in 3.1 don't mount git
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Bradley Childs
Jianwei Hou
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 16:29 EST by Jay Vyas
Modified: 2017-08-16 15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Volumes in 3.1 don't mount git Consequence: Git Volumes wouldn't mount Fix: Code Change Result: Git volumes mount
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-15 10:31:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Vyas 2016-03-01 16:29:52 EST
Description of problem:

In certain OSE versions < 3.2, git volumes won't mount.  This was a fixed upstream issue, but fixed after OSE 3.1 


Version-Release number of selected component (if applicable):

oc v3.1.1.6-21-gcd70c35
kubernetes v1.1.0-origin-1107-g4c8e6f4

How reproducible:



Steps to Reproduce:
1. Run kube e2e tests with focus="EmptyDir wrapper volumes"

Actual results:

Test fails: Diving into container logs, Pod doesnt mount because the pod dir isn't created by kube.


Expected results:

Test passes.

Additional info:


The fix:  Update OSE to 3.2, or make titrate the patch https://github.com/kubernetes/kubernetes/pull/18445 into OSE 3.1 release streams
Comment 1 Bradley Childs 2016-03-03 11:26:43 EST
This is fixed here:

https://github.com/kubernetes/kubernetes/pull/18445
Comment 3 Mike McCune 2016-03-28 18:18:06 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Eric Paris 2017-06-15 10:31:08 EDT
I'm just going to close this. It's not something we are actively working on and was fixed long ago.

Note You need to log in before you can comment on or make changes to this bug.