Bug 1313572 - Rules engine does not accept regex when performing recursive action validation
Rules engine does not accept regex when performing recursive action validation
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Internal Tools (Show other bugs)
4.4
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: Jeff Fearn
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 18:25 EST by John Poelstra
Modified: 2016-09-22 04:09 EDT (History)
5 users (show)

See Also:
Fixed In Version: 4.4.12058-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-04 20:38:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (190.37 KB, image/png)
2016-03-01 18:25 EST, John Poelstra
no flags Details

  None (edit)
Description John Poelstra 2016-03-01 18:25:33 EST
Created attachment 1132083 [details]
screenshot

Description of problem:

Rules engine does not accept regex when performing recursive action validation.

I had to add a second validation rule to check that my flag was "unset" to shut up the big red error box (see attached).

See example: https://bugzilla.redhat.com/page.cgi?id=ruleengine/edit.html&action=update&rule_id=72

What's even more annoying is that existing rules that are running fine, suddenly through a similar error after you edit them or clone them.

Cloning is even more aggravating because you've gone through input on all the screens and there is no way to save your work because it keeps complaining about the bogus missing validation routine.
Comment 1 Jeff Fearn 2016-07-31 22:05:13 EDT
*** Bug 1360606 has been marked as a duplicate of this bug. ***
Comment 2 Rony Gong 2016-08-07 22:18:02 EDT
Tested on QA environment(4.4.12058-1)
Result: Pass
Steps:
1.Try to edit this rule 'Ceph: set proposed release flag for new bugs'(https://bzweb.host.qe.eng.pek2.redhat.com/page.cgi?id=ruleengine/edit.html&action=update&rule_id=72), click 'Next' button until step 4, 
==>Page show error:

It appears that you have a rule action setting the following fields but no rule criteria checking that at least one of these values is not already set.

field	value
flag ceph-1.3.z	?
Comment 3 Jeff Fearn 2016-08-11 01:50:56 EDT
Tried to test this but the server has an issue with it's database, has Ops been notified?
Comment 4 Rony Gong 2016-08-16 03:30:06 EDT
Tested on QA environment(4.4.12058-2)
Result: Pass
Comment 5 Jeff Fearn 2016-09-04 20:38:03 EDT
This change is now live. If there are any issues, do not reopen this bug. Instead, you should create a new bug and reference this bug.

Note You need to log in before you can comment on or make changes to this bug.