Bug 1313596 - remote execution plugin not installed by default on a capsule or satellite
Summary: remote execution plugin not installed by default on a capsule or satellite
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Stephen Benjamin
QA Contact: jcallaha
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-02 01:27 UTC by Justin Sherrill
Modified: 2019-09-25 21:17 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:03:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Justin Sherrill 2016-03-02 01:27:00 UTC
Description of problem:

When installing a capsule (or satellite) the remote execution ssh plugin is not installed alongside the smart proxy and thus the proxy cannot be used for remote execution

Version-Release number of selected component (if applicable):
6.2 Snap 1

How reproducible:


Steps to Reproduce:
1.  Install a satellite (and a capsule to the existing satellite)
2.  Visit the Capsules page (switching to any context)
3.  look for the remote execution ssh 'feature'.  It should be there with the default installs.

Comment 6 Peter Ondrejka 2016-03-31 10:33:20 UTC
Should the CLI module for remote execution (tfm-rubygem-hammer_cli_foreman_remote_execution) be also installed by default?

Comment 8 Stephen Benjamin 2016-03-31 21:23:24 UTC
I would say not as part of this bug.

Please file an additional bug because we're not installing other CLI plugins too.
For example, hammer_cli_foreman_discovery is also missing.

Comment 9 jcallaha 2016-04-01 14:50:12 UTC
Verified in Satellite 6.2 Beta Snap 6. Remote execution plugins installed by default. Will file a new bug for missing CLI plugins.

Comment 12 errata-xmlrpc 2016-07-27 09:03:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.