Bug 1313597 - Cron jobs are not run anymore after a day or so.
Cron jobs are not run anymore after a day or so.
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Image (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Vu Dinh
Wenjing Zheng
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 20:28 EST by Michael
Modified: 2016-03-02 14:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-02 14:51:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael 2016-03-01 20:28:20 EST
Description of problem:
Cron jobs are not run anymore after a day or so.

Version-Release number of selected component (if applicable):
cron-1.4
python-3.3

How reproducible:
I tried to create new python-3.3 apps from scratch several times, installing/uninstalling the cron component several times.
It does not change anything, it works for a day or so and then the jobs are not run anymore when looking at the logs:
`cat ~/app-root/logs/cron_hourly.log  | grep 'START hourly cron run'`

I don't see any errors in the logs, just that the jobs are not run anymore.

Actual results:
The hourly cron jobs are not run anymore after a day or so.

Expected results:
The hourly cron jobs are supposed to be run every hour.
Comment 1 Michael 2016-03-02 09:02:01 EST
I just saw this comment when I ssh'ed into the app:

    ***  This gear has been temporarily unidled. To keep it active, access
    ***  your app @ http://<appname>.rhcloud.com/

I'm not sure if it is why the cron jobs were not running anymore.
Can that be the reason? Idling stops the cron jobs as well?
Comment 2 Vu Dinh 2016-03-02 14:51:37 EST
Hi Michael,

If your app is idled, the cron job will be idled as well hence it will not run. Since you are using free tier of OpenShift Online, your app will be automatically idled if there is no access to it in 24 hour period.

Thanks,
Vu

Note You need to log in before you can comment on or make changes to this bug.