This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1313604 - 3.5 maven build failure due to codehaus.org repository being retired
3.5 maven build failure due to codehaus.org repository being retired
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Build.Maven (Show other bugs)
3.5.0
Unspecified Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: Sandro Bonazzola
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 21:40 EST by Greg Sheremeta
Modified: 2017-05-11 05:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-04 09:25:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 54327 None None None 2016-03-04 09:25 EST

  None (edit)
Description Greg Sheremeta 2016-03-01 21:40:32 EST
Description of problem:
codehaus is dead -- must remove references to the old codehaus repo in 3.5's pom

the build will fail because snmp4j is getting pulled from codehaus and not oosnmp.net

Version-Release number of selected component (if applicable):
3.5 master

How reproducible:
always

Steps to Reproduce:
1. checkout 3.5 (i used a fresh vm)
2. delete local maven repository
3. make

Actual results:
the build will fail

Expected results:
successful build

Additional info:
this patch should roughly do it

diff --git a/pom.xml b/pom.xml
index 404668a..10215ed 100644
--- a/pom.xml
+++ b/pom.xml
@@ -403,14 +403,6 @@
       </releases>
     </repository>
     <repository>
-      <id>codehaus</id>
-      <name>Codehaus Releases</name>
-      <url>http://repository.codehaus.org/</url>
-      <snapshots>
-        <enabled>false</enabled>
-      </snapshots>
-    </repository>
-    <repository>
       <id>snmp4j</id>
       <name>snmp4j</name>
       <url>https://oosnmp.net/dist/release/</url>
Comment 1 Martin Perina 2016-03-02 02:30:46 EST
AFAIK we are not supposed to build oVirt 3.5 anymore. RHEV 3.5 build is done in a different way, so it shouldn't be affected. I looked at master/3.6 and we don't use this repo anymore. So shouldn't it be closed as WONTFIX?
Comment 2 Greg Sheremeta 2016-03-02 09:32:43 EST
@Martin, you have a point, but it's a pretty harmless patch and saves people a lot of frustration when we're backporting patches.
Comment 3 Martin Perina 2016-03-02 12:24:00 EST
@Greg, I asked about the reason of the bug/fix, because there won't be any other 3.5 build (3.5.8 downstream was the last one), which means we will no longer need to backport any patches to 3.5 branch.

But anyway, feel free to send a patch for this if you think it's still needed.
Comment 4 Greg Sheremeta 2016-03-02 12:26:19 EST
I'm not actually applying fixes to 3.5, but I'm regression testing performance issues between 4.0, 3.6, and 3.5. Which requires the ability to build 3.5 :)
Comment 5 Sandro Bonazzola 2016-03-04 07:45:33 EST
Ok on my side for fixing the build there.

Note You need to log in before you can comment on or make changes to this bug.