Bug 1313614 - dnf's curl error in repositories fetching prevents from using dnf
dnf's curl error in repositories fetching prevents from using dnf
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
25
Unspecified Linux
low Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 23:13 EST by M.Hanny Sabbagh
Modified: 2017-06-27 04:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-27 04:10:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dnf.log (29.67 KB, text/plain)
2016-03-01 23:13 EST, M.Hanny Sabbagh
no flags Details
Ojuba Linux repository (365 bytes, text/plain)
2016-03-01 23:14 EST, M.Hanny Sabbagh
no flags Details
The terminal's output of dnf (330 bytes, text/plain)
2016-03-01 23:18 EST, M.Hanny Sabbagh
no flags Details

  None (edit)
Description M.Hanny Sabbagh 2016-03-01 23:13:42 EST
Created attachment 1132130 [details]
dnf.log

Description of problem:

When you add a repository that contains some errors(redirection errors potentially) to dnf, and you try to upgrade or install some packages, dnf will just lag and won't do anything, the reason is (as far as I can see from the log files) is because curl failed to fetch the repository's information successfully, therefore dnf will just lag. This happened right now for me because of Ojuba Linux repository (a distribution that is based on Fedora, the repository right not is not working at all), so you may try to add it and test to see what really happens.


Version-Release number of selected component (if applicable): 1.1.6-2.fc23.noarch


How reproducible: 


Steps to Reproduce:
1. Add the Ojuba repository to your system from the file in the attachments.
2. run dnf upgrade --refresh, or even update or install.

Actual results:
1. You will see that dnf stopped doing anything, it lagged.

Expected results:
1. dnf should have disabled the repository automatically and continued upgrading/installing from other working repositories.


Additional info: Please check the log files.
Comment 1 M.Hanny Sabbagh 2016-03-01 23:14 EST
Created attachment 1132131 [details]
Ojuba Linux repository
Comment 2 M.Hanny Sabbagh 2016-03-01 23:18 EST
Created attachment 1132133 [details]
The terminal's output of dnf
Comment 3 M.Hanny Sabbagh 2016-03-01 23:21:12 EST
By the way, after I removed Ojuba repository file from /etc/yum.repos.d dnf went back to working normally again.
Comment 4 Honza Silhan 2016-03-14 11:31:20 EDT
Thanks for the report, we'll take a look.
Comment 5 Fedora Admin XMLRPC Client 2016-07-08 05:37:51 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Igor Gnatenko 2016-07-21 10:35:23 EDT
Well, this is definitely notabug as you should add skip_if_unavailable=True to repo file.

But I agree if stric=False it's probably need to skip automatically.
Comment 7 Jan Kurik 2016-07-26 01:02:35 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.
Comment 8 Jaroslav Mracek 2017-06-27 04:10:03 EDT
We have several reported issues for Fedora 22 or 23, connected with libcurl, but all of them already were solved including this one. Please if anyone will be able to reproduce the issue with dnf-2.5.1+ that is available for rawhide, Fedora 26 or from our testing repository for Fedora 24+ (dnf copr enable rpmsoftwaremanagement/dnf-nightly), don't hesitate to reopen the bug report and I will investigate it. 

I also don't think that it is good idea to combine functionality of strict option or --skip-broken with overwritten of skip_if_unavailable, because it is very dangerous and it can produce unexpected results. Repos that requires available  metadata can be anytime disabled from commandline by user (--disablerepo).

Note You need to log in before you can comment on or make changes to this bug.