This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1313631 - Traceback when registering by subscription-manager-gui to Satellite6 org containing one environment
Traceback when registering by subscription-manager-gui to Satellite6 org cont...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.8
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Chris Snyder
John Sefler
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 01:22 EST by qianzhan
Modified: 2016-05-10 16:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:40:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhsm.log (305.04 KB, text/plain)
2016-03-02 01:23 EST, qianzhan
no flags Details
traceback_during_registration_by_gui_in_s390x.png (197.65 KB, image/png)
2016-03-02 01:23 EST, qianzhan
no flags Details

  None (edit)
Description qianzhan 2016-03-02 01:22:22 EST
Description of problem:
Traceback when registration by subscription-manager-gui in s390x

Version-Release number of selected component (if applicable):
subscription-manager: 1.16.8-3.el6
python-rhsm: 1.16.6-1.el6

How reproducible:
always

Steps to Reproduce:
1. Install RHEL-6.8-server-s390x-20160225.0
2. Open subscription-manager-gui, and register to Satellite-6.1.0-RHEL-7-20160209.1


Actual results:
Registration window shows registering all the time, and the registering process can not finished. There is a traceback on terminal.(Please see attachment 'traceback_during_registration_by_gui_in_s390x.png')

Expected results:
Registration should succeed.

Additional info:
Registration with CLI is successful.

Attachment'rhsm.log' is the rhsm.log
Comment 1 qianzhan 2016-03-02 01:23 EST
Created attachment 1132150 [details]
rhsm.log
Comment 2 qianzhan 2016-03-02 01:23 EST
Created attachment 1132151 [details]
traceback_during_registration_by_gui_in_s390x.png
Comment 9 John Sefler 2016-03-16 16:50:11 EDT
Verifying Version...

[root@jsefler-6 ~]# rpm -q subscription-manager-gui
subscription-manager-gui-1.16.8-5.el6.x86_64

[root@jsefler-6 ~]# rpm --quiet -Uvh http://sat-r220-06.lab.eng.rdu2.redhat.com/pub/katello-ca-consumer-latest.noarch.rpm
########################################### [100%]
########################################### [100%]
[root@jsefler-6 ~]# subscription-manager orgs --username=admin
Password: 
+-------------------------------------------+
          admin Organizations
+-------------------------------------------+

Name: Default Organization
Key:  Default_Organization

Name: Gibson Inc
Key:  Gibson_Inc

Name: Lazy Sync Org
Key:  Lazy_Sync_Org

Name: Mega Corporation
Key:  megacorp

Name: ORGFive
Key:  ORGFive

Name: Shire
Key:  Shire

Name: The Demo Org Auto
Key:  The_Demo_Org_Auto

Name: ZomboCom
Key:  ZomboCom

[root@jsefler-6 ~]# subscription-manager environments --username=admin --org=Default_Organization
Password: 
+-------------------------------------------+
          Environments
+-------------------------------------------+
Name:        Library
Description: 

[root@jsefler-6 ~]# 

NOTE THAT ONLY ONE ENVIRONMENT IS AVAILABLE TO USER admin UNDER ORG Default_Organization
REGISTERING WITH subscription-manager-gui

[root@jsefler-6 ~]# subscription-manager-gui --register

VERIFIED USING THE GUI: (NOT SHOWN) I WAS ABLE TO REGISTER TO ORG Default_Organization AND CLOSE THE GUI.  NO TRACEBACK.

[root@jsefler-6 ~]# subscription-manager identity
system identity: 96e88865-a479-405a-b9da-5ea4764fd894
name: jsefler-6.usersys.redhat.com
org name: Default Organization
org ID: Default_Organization
environment name: Library
Comment 11 errata-xmlrpc 2016-05-10 16:40:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0797.html

Note You need to log in before you can comment on or make changes to this bug.