Bug 1313664 - Unable to delete discovered hosts via multi-selections
Unable to delete discovered hosts via multi-selections
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Discovery Plugin (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: Beta
: --
Assigned To: Lukas Zapletal
Sachin Ghai
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 02:36 EST by Lukas Zapletal
Modified: 2016-07-27 05:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:24:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13715 None None None 2016-04-22 12:18 EDT

  None (edit)
Description Lukas Zapletal 2016-03-02 02:36:57 EST
When trying to delete discovered hosts via multi-selector, getting undefined method `delete_if'. Regression.
Comment 2 Bryan Kearney 2016-03-02 04:03:13 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13715 has been closed
-------------
Anonymous
Applied in changeset commit:foreman_discovery|4a3065ab7c2111a80a3af004d4ad0e91726c326d.
Comment 4 Sachin Ghai 2016-03-10 07:18:00 EST
Verified with sat6.2 snap3. The reported issue is fixed. I can delete the discovered hosts via multi selection.


2016-03-10 13:15:54 [app] [I] Started POST "/discovered_hosts/submit_multiple_destroy?host_ids%5B%5D=3" for 10.65.193.200 at 2016-03-10 13:15:54 +0100
2016-03-10 13:15:54 [app] [I] 2016-03-10 13:15:54 [app] [I] Started POST "/discovered_hosts/submit_multiple_destroy?host_ids%5B%5D=3" for 10.65.193.200 at 2016-03-10 13:15:54 +0100
2016-03-10 13:15:54 [app] [I] Processing by DiscoveredHostsController#submit_multiple_destroy as HTML
2016-03-10 13:15:54 [app] [I]   Parameters: {"utf8"=>"✓", "authenticity_token"=>"+e1GaMx9dDLPcz9e30jXEgMW+e0ROv6fozQCV3N8BlU=", "host_ids"=>["3"]}
2016-03-10 13:15:54 [app] [I] Redirected to https://ibm-x3550m3-07.lab.eng.brq.redhat.com/discovered_hosts
2016-03-10 13:15:54 [app] [I] Completed 302 Found in 74ms (ActiveRecord: 23.5ms)
2016-03-10 13:15:55 [app] [I] Started GET "/discovered_hosts" for 10.65.193.200 at 2016-03-10 13:15:55 +0100
2016-03-10 13:15:55 [app] [I] Processing by DiscoveredHostsController#index as HTML
2016-03-10 13:15:55 [app] [I]   Rendered /opt/theforeman/tfm/root/usr/share/gems/gems/foreman_discovery-5.0.0.1/app/views/discovered_hosts/_discovered_hosts_list.html.erb (16.3ms)
2016-03-10 13:15:55 [app] [I]   Rendered /opt/theforeman/tfm/root/usr/share/gems/gems/foreman_discovery-5.0.0.1/app/views/discovered_hosts/index.html.erb within layouts/application (33.5ms)
2016-03-10 13:15:55 [app] [I]   Rendered common/_searchbar.html.erb (7.3ms)
2016-03-10 13:15:55 [app] [I]   Rendered layouts/_application_content.html.erb (8.0ms)
2016-03-10 13:15:55 [app] [I]   Rendered home/_submenu.html.erb (3.4ms)
2016-03-10 13:15:55 [app] [I]   Rendered home/_user_dropdown.html.erb (3.9ms)
2016-03-10 13:15:55 [app] [I] Read fragment views/tabs_and_title_records-3 (0.2ms)
2016-03-10 13:15:55 [app] [I]   Rendered home/_topbar.html.erb (9.8ms)
2016-03-10 13:15:55 [app] [I]   Rendered layouts/base.html.erb (12.8ms)
2016-03-10 13:15:55 [app] [I] Completed 200 OK in 74ms (Views: 54.3ms | ActiveRecord: 4.7ms)
Comment 7 errata-xmlrpc 2016-07-27 05:24:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.