Bug 1313671 - Hostgroup with rules is not prevented from deletion
Hostgroup with rules is not prevented from deletion
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Discovery Plugin (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: Lukas Zapletal
Sachin Ghai
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 02:58 EST by Lukas Zapletal
Modified: 2016-07-27 05:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:24:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 11574 None None None 2016-04-22 12:02 EDT

  None (edit)
Description Lukas Zapletal 2016-03-02 02:58:36 EST
An attempt to delete a hostgroup with a rule associated does not end with an error leaving rule uninitialized leaving database in inconsistent state.

Auto-provisioning for this rule then fails hard.
Comment 2 Bryan Kearney 2016-03-02 04:09:59 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/11574 has been closed
-------------
Anonymous
Applied in changeset commit:foreman_discovery|82d93bfb7748482ca32ab293d8c0b47c38c4c018.
Comment 3 Sachin Ghai 2016-03-10 07:25:13 EST
Verified with sat6.2 snap3.

Now if user try to delete a hostgroup which is associated to discovery rule, User will see  proper error:


2016-03-10 13:21:39 [app] [I] Started DELETE "/hostgroups/1-sat_rhel7_hg" for 10.65.193.200 at 2016-03-10 13:21:39 +0100
2016-03-10 13:21:39 [app] [I] Processing by HostgroupsController#destroy as HTML
2016-03-10 13:21:39 [app] [I]   Parameters: {"authenticity_token"=>"+e1GaMx9dDLPcz9e30jXEgMW+e0ROv6fozQCV3N8BlU=", "id"=>"1-sat_rhel7_hg"}
2016-03-10 13:21:40 [app] [I] Failed to save: Cannot delete record because dependent discovery rules exist
2016-03-10 13:21:40 [app] [I] Redirected to https://ibm-x3550m3-07.lab.eng.brq.redhat.com/hostgroups
Comment 6 errata-xmlrpc 2016-07-27 05:24:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.