Bug 131368 - 'import gnome.applet' causes ABRT, SEGV
'import gnome.applet' causes ABRT, SEGV
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-python2 (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks: FC3Target 131589
  Show dependency treegraph
 
Reported: 2004-08-31 12:24 EDT by Zack Cerza
Modified: 2013-04-02 00:19 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.6.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 17:24:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ABRT backtrace from gdb (2.44 KB, text/plain)
2004-08-31 12:27 EDT, Zack Cerza
no flags Details
SEGV backtrace from gdb (2.11 KB, text/plain)
2004-08-31 12:29 EDT, Zack Cerza
no flags Details

  None (edit)
Description Zack Cerza 2004-08-31 12:24:32 EDT
Description of problem:
The following python script will cause an ABRT signal to be emitted:
#!/usr/bin/python2
import gnome.applet
The error message given is: "GLib-ERROR **: gmem.c:157: failed to
allocate 18446744066786085920 bytes"

The following python script will cause a SEGV signal to be emitted:
#!/usr/bin/python2
import gtk
import gnome.applet

Version-Release number of selected component (if applicable):
gnome-python2-applet-2.0.2-1

How reproducible:
Always

Additional info:
If these are two separate bugs, I can split the report into two. I'm
not too worried about the ABRT problem, since I'm fairly sure you're
supposed to import gtk before gnome.applet.
Comment 1 Zack Cerza 2004-08-31 12:27:13 EDT
Created attachment 103299 [details]
ABRT backtrace from gdb
Comment 2 Zack Cerza 2004-08-31 12:29:06 EDT
Created attachment 103301 [details]
SEGV backtrace from gdb
Comment 3 Zack Cerza 2004-10-05 17:24:46 EDT
Seems fixed =D

Note You need to log in before you can comment on or make changes to this bug.