Bug 1313697 - Host card fails to report OS because lsb_release is not installed on the machine
Host card fails to report OS because lsb_release is not installed on the machine
Status: CLOSED WONTFIX
Product: Red Hat Storage Console
Classification: Red Hat
Component: core (Show other bugs)
2
Unspecified Unspecified
unspecified Severity low
: ---
: 2
Assigned To: anmol babu
sds-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 04:12 EST by Martin Bukatovic
Modified: 2016-05-24 05:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-24 05:04:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of Hosts page (48.26 KB, image/png)
2016-03-02 04:13 EST, Martin Bukatovic
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Gerrithub.io 277132 None None None 2016-05-24 04:56 EDT

  None (edit)
Description Martin Bukatovic 2016-03-02 04:12:29 EST
Description of problem
======================

Host cards of some machines fail to report version of the operating system
properly.

Version-Release number of selected component
============================================

USM machine:
rhscon-ceph-0.0.6-10.el7.x86_64
rhscon-core-0.0.8-9.el7.x86_64
rhscon-ui-0.0.18-1.el7.noarch

USM MON machine:
rhscon-agent-0.0.3-3.el7.noarch

USM OSD machines:
rhscon-agent-0.0.3-3.el7.noarch

How reproducible
================

100 %

Steps to Reproduce
==================

1. Install USM according to the documentation
2. Accept all hosts
3. Go to Hosts page

Actual results
==============

On the Hosts page, cards of future OSD machines reports the following:

~~~
OS :  lsb_release: command
~~~

While cards of future MON machines reports:

~~~
OS :  RedHatEnterpriseServer 7.2
~~~

Expected results
================

No matter of a type of a machine, all cards should report the OS properly
like this:

~~~
OS :  RedHatEnterpriseServer 7.2
~~~

Additional info
===============

This is likely caused by the fact that lsb_release is not installed on
OSD machines:

~~~
[root@mbukatov-usm1-node1 ~]# # lsb_release
-bash: lsb_release: command not found
~~~

But it's available on MON machine:

~~~
[root@mbukatov-usm1-mon1 ~]# lsb_release 
LSB Version:	:core-4.1-amd64:core-4.1-noarch
[root@mbukatov-usm1-mon1 ~]#  rpm -qa 'rhscon*
~~~

Also note that on usm cluster I deployed in a previous week, 
redhat-lsb-core-4.1-27.el7.x86_64 package was installed on all machines.
Comment 1 Martin Bukatovic 2016-03-02 04:13 EST
Created attachment 1132195 [details]
screenshot of Hosts page
Comment 4 anmol babu 2016-05-24 05:04:19 EDT
This has been fixed in the api but, the detail has been removed from latest UI mock up as in https://docs.google.com/presentation/d/1E7ZHHMYufugMjuVceluP7FCfUM9CQNsN5QWmGruRth0/edit#slide=id.gae7c907e0_0_12

Note You need to log in before you can comment on or make changes to this bug.