Bug 1313764 - PyOpenSSL dependency missing in packstack
PyOpenSSL dependency missing in packstack
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
7.0 (Kilo)
All Linux
medium Severity high
: ---
: 7.0 (Kilo)
Assigned To: Ivan Chavero
Shai Revivo
: ZStream
: 1319580 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 05:18 EST by Prateek Arora
Modified: 2017-07-24 13:07 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-packstack-2015.1-0.17.dev1589.g1d6372f.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-05 14:47:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prateek Arora 2016-03-02 05:18:49 EST
Description of problem:

Packstack fails installation when PyOpenSSL is not present in the system with the error

ImportError: No module named OpenSSL


Version-Release number of selected component (if applicable):
RHOS7, RHEL7


How reproducible:

Every time

Steps to Reproduce:
1. Take a system which does not have PyOpenSSL
or if it has the module(you can check it using below command)
 
rpm -qa|grep -i pyopenssl
pyOpenSSL-0.13.1-3.el7.x86_64

yum remove it

2. Register and subscribe to Openstack 7 Repos

3. Install openstack-packstack

4. Run packstack --allinone

Actual results:

ERROR:root:Failed to load plugin from file prescript_000.py
ERROR:root:Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 885, in loadPlugins
    moduleobj = __import__(moduleToLoad)
  File "/usr/lib/python2.7/site-packages/packstack/plugins/prescript_000.py", line 36, in <module>
    from packstack.modules.ospluginutils import appendManifestFile
  File "/usr/lib/python2.7/site-packages/packstack/modules/ospluginutils.py", line 17, in <module>
    from OpenSSL import crypto
ImportError: No module named OpenSSL


Expected results:

Installation should be successful

Additional info:
Comment 2 Prateek Arora 2016-03-07 06:12:52 EST
Hi

Do we have any update on this bug ?
Comment 3 Ivan Chavero 2016-03-14 12:29:59 EDT
Current packstack package for OSP 8 already has this dependency. Can you check again please?
Comment 5 Ivan Chavero 2016-03-19 16:29:20 EDT
I've added the dependency to the OSP 7 package, can i have acks in order to build it please?
Comment 6 Ivan Chavero 2016-03-19 17:33:21 EDT
I've changed the target release to 7.0
Comment 11 Ivan Chavero 2016-03-21 13:22:32 EDT
*** Bug 1319580 has been marked as a duplicate of this bug. ***
Comment 14 Prateek Arora 2016-03-23 09:07:12 EDT
Hi can you please rebuild the brew rpms ?
Comment 15 Prateek Arora 2016-04-15 07:40:29 EDT
Ivan 

The latest package with the resolution to this problem is not available right now. Please let me know by when would it be available ?
Comment 17 Vladimir Rusinov 2016-04-25 12:05:28 EDT
This duplicates: 1301361 which was reported earlier.

Looks like I don't have permissions to close this bug as duplicate, or at least can't figure out how to do that.
Comment 24 nlevinki 2016-10-05 06:39:23 EDT
Automation passed
https://rhos-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/RHOS/view/RHOS7/job/qe-7_director-rhel-7.2-virthost-1cont_1comp_1ceph-ipv4-vxlan-ceph-ssl/3/
using this rpm
openstack-packstack-2015.1-0.19.dev1589.g1d6372f.el7ost.noarch
Comment 26 errata-xmlrpc 2016-10-05 14:47:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2016.html

Note You need to log in before you can comment on or make changes to this bug.