Bug 1313775 - ec-read-policy.t can report a false-failure
ec-read-policy.t can report a false-failure
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: disperse (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Xavi Hernandez
: Reopened, Triaged
Depends On:
Blocks: 1313776
  Show dependency treegraph
 
Reported: 2016-03-02 05:34 EST by Xavi Hernandez
Modified: 2016-06-16 09:59 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1313776 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:59:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xavi Hernandez 2016-03-02 05:34:44 EST
Description of problem:

One of the tests in ec-read-policy.t checks for READ operations in all bricks using the output of a 'gluster volume profile' command and couting lines containing "READ". This can fail if, for some reason, one or more bricks has also executed a READDIR fop.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2016-03-02 05:36:37 EST
REVIEW: http://review.gluster.org/13575 (tests: Fix spurious failure of ec-read-policy.t) posted (#1) for review on master by Xavier Hernandez (xhernandez@datalab.es)
Comment 2 Vijay Bellur 2016-03-03 16:12:14 EST
REVIEW: http://review.gluster.org/13575 (tests: Fix spurious failure of ec-read-policy.t) posted (#2) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 3 Vijay Bellur 2016-03-04 10:48:01 EST
COMMIT: http://review.gluster.org/13575 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit bf80b9005240811d931090afcfee8ca0b02f8212
Author: Xavier Hernandez <xhernandez@datalab.es>
Date:   Wed Mar 2 11:35:44 2016 +0100

    tests: Fix spurious failure of ec-read-policy.t
    
    Change-Id: I5297e24dd10cbfbcd671fe630ae3e960b9daa8f8
    BUG: 1313775
    Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    Reviewed-on: http://review.gluster.org/13575
    Tested-by: Raghavendra Talur <rtalur@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 4 Raghavendra Talur 2016-03-08 15:00:59 EST
"tests" component is for tests framework only.
File a bug under test component if you find a bug in 
1. any of the *.rc files under tests/ 
2. run-tests.sh


For everything else, the bug should be filed on
1. component which is being tested by .t file if the .t file requires fix.
2. component which is causing a valid .t file to fail in regression.

I have used my best judgement here to move the bug to right component.
In case of ambiguity, I have placed the blame on the .t file component.

Please consider test bugs under the same backlog list that tracks other bugs in your component.
Comment 5 Niels de Vos 2016-06-16 09:59:06 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.