Bug 1313777 - Boot images names in discovery stanza of 'PXELinux global default' template needs to be updated
Summary: Boot images names in discovery stanza of 'PXELinux global default' template n...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Discovery Plugin
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Lukas Zapletal
QA Contact: Sachin Ghai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-02 10:39 UTC by Sachin Ghai
Modified: 2019-09-26 17:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:24:36 UTC
Target Upstream Version:


Attachments (Terms of Use)
PXELinux global default template stil contains image names as per upstream templates (79.10 KB, image/png)
2016-03-10 11:02 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Sachin Ghai 2016-03-02 10:39:29 UTC
Description of problem:

In Sat 6.2 snap1, the "PXELinux global default template" includes following discovery stanza:

LABEL discovery
     MENU LABEL (discovery)
     KERNEL boot/fdi-image/vmlinuz0
     APPEND initrd=boot/fdi-image/initrd0.img rootflags=loop root=live:/fdi.iso rootfstype=auto ro rd.live.image acpi=force rd.luks=0 rd.md=0 rd.dm=0 rd.lvm=0 rd.bootif=0 rd.neednet=0 nomodeset proxy.url=https://FOREMAN_INSTANCE proxy.type=foreman
     IPAPPEND 2


This needs to be updated like:

LABEL discovery
MENU LABEL Satellite 6 Discovery
MENU DEFAULT
KERNEL boot/fdi-image-rhel_7-vmlinuz
APPEND initrd=boot/fdi-image-rhel_7-img rootflags=loop root=live:/fdi.iso rootfstype=auto ro rd.live.image acpi=force rd.luks=0 rd.md=0 rd.dm=0 rd.lvm=0 rd.bootif=0 rd.neednet=0 nomodeset proxy.url=https://SATELLITE_CAPSULE_URL:9090 proxy.type=proxy
IPAPPEND 2


Here boot images needs to be updated as per the image names extracted from the foreman-discovery-image rpm.

Version-Release number of selected component (if applicable):
Satellite 6.2 snap1

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
Here boot images needs to be updated as per the image names extracted from the foreman-discovery-image rpm.

Additional info:

Comment 2 Lukas Zapletal 2016-03-02 11:57:15 UTC
Thanks, yes. Rebasing Foreman core templates pulled this in. Our documentation still contains instructions how to add proper part, but as this is confusing, I recommend to create a downstream only patch to remove the upstream block and add a *commented* block from our documentation.

Comment 4 Sachin Ghai 2016-03-10 11:00:18 UTC
I can still see old changes as per upstream template with sat6.2 snap3.

Comment 5 Sachin Ghai 2016-03-10 11:02:12 UTC
Created attachment 1134813 [details]
PXELinux global default template stil contains image names as per upstream templates

Comment 6 Sachin Ghai 2016-03-28 09:07:24 UTC
Verified sat6.2 beta snap5.1


I can see updated 'PXELinux global default' template. Path to discovery images updated there as per downstream names.

--

LABEL discovery
     MENU LABEL (discovery)
     KERNEL boot/fdi-image-rhel_7-vmlinuz
     APPEND initrd=boot/fdi-image-rhel_7-img rootflags=loop root=live:/fdi.iso rootfstype=auto ro rd.live.image acpi=force rd.luks=0 rd.md=0 rd.dm=0 rd.lvm=0 rd.bootif=0 rd.neednet=0 nomodeset proxy.url=https://SATELLITE_CAPSULE_URL:9090 proxy.type=proxy
     IPAPPEND 2

--

Comment 9 errata-xmlrpc 2016-07-27 09:24:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.