Bug 1313785 - withlock: Switch to Python 3
withlock: Switch to Python 3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: withlock (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Williamson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PYTHON3 PY3PATCH-REQUESTED
  Show dependency treegraph
 
Reported: 2016-03-02 05:56 EST by Petr Viktorin
Modified: 2016-05-20 15:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-20 15:32:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Viktorin 2016-03-02 05:56:01 EST
Upstream (in version 0.5), this software supports Python 3.
Please provide a Python 3 package for Fedora.


According to the Python packaging guidelines [0], software must be
packaged for Python 3 if upstream supports it.
The guidelines give detailed information on how to do this, and even
provide an example spec file [1].

Since users aren't expected to import this tool from Python code,
you can just switch to /usr/bin/python3. Alternatively, if you want or
need to keep a Python 2 version, the current best practice is to provide
subpackages -- this is called "Common SRPM" in the guidelines.

It's ok to do this in Rawhide only, however, it would be greatly
appreciated if you could push it to Fedora 24 as well.


If anything is unclear, or if you need any kind of assistance with the
porting, you can ask on IRC (#fedora-python on Freenode), or reply here.
We'll be happy to help!


[0] https://fedoraproject.org/wiki/Packaging:Python
[1] https://fedoraproject.org/wiki/Packaging:Python#Example_common_spec_file
Comment 1 Dominika Krejčí 2016-04-22 05:11:22 EDT
Hello Adam,

Do you need any help adding Python 3 support to the RPM?

If you need more instructions, a [guide] for porting Python-based RPMs is available.

[guide] http://python-rpm-porting.readthedocs.org/en/latest/index.html
Comment 2 Adam Williamson 2016-04-22 10:20:19 EDT
no, I thought I'd already done it...lemme check.
Comment 3 Dominika Krejčí 2016-05-04 05:18:14 EDT
How are things going, Adam? I still see the old version, which supports only Python 2.
Comment 4 Adam Williamson 2016-05-04 10:34:06 EDT
It never gets very high up my priority list...

Note You need to log in before you can comment on or make changes to this bug.