Bug 1313798 - Console output post ipa-winsync-migrate command should be corrected.
Console output post ipa-winsync-migrate command should be corrected.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 06:13 EST by Sudhir Menon
Modified: 2016-11-04 01:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: ipa-4.4.0-0.el7.1.alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:51:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
console logs (8.70 KB, text/plain)
2016-03-02 06:13 EST, Sudhir Menon
no flags Details

  None (edit)
Description Sudhir Menon 2016-03-02 06:13:17 EST
Created attachment 1132253 [details]
console logs

Description of problem: ipa-migrate-winsync should be ipa-winsync-migrate.

Version-Release number of selected component (if applicable):

How reproducible:Always


Steps to Reproduce:

1. Install IPA-server on RHEL7.2.
2. Create a winsync agreement with Windows AD 2012R2
3. Now add two-way AD trust with same windows 2012R2 AD
4. Now run ipa-winsync-migrate in verbose mode.

Actual results:
winsync migration happens successfully. But the output displayed on the console mentions "The ipa-migrate-winsync command was successful" 

Expected results:
There is no command as 'ipa-migrate-winsync'.
Change the output description to "The ipa-winsync-migrate command was successful"

Additional info:
Attaching the console log shown in verbose mode.
Comment 2 Petr Vobornik 2016-03-02 06:34:05 EST
same issue(same root cause) is in `ipa-winsync-migrate --help` output.
Comment 3 Petr Vobornik 2016-03-02 06:35:42 EST
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5713
Comment 4 Petr Vobornik 2016-03-02 07:56:09 EST
fixed upstream

ipa-4-2:
    7151ea394aac00ca596a8d7460a2fcefd258b36e fix incorrect name of ipa-winsync-migrate command in help 

ipa-4-3:
    57e02c7140fe2ad6fe6a6bc9823f84500bb78732 fix incorrect name of ipa-winsync-migrate command in help 

master:
    c68e9510d03abb75d353e209ea32ac9d1ed362bc fix incorrect name of ipa-winsync-migrate command in help
Comment 5 Mike McCune 2016-03-28 18:43:24 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 7 Sudhir Menon 2016-07-20 05:32:18 EDT
Fix is seen.
Verified using ipa-server-4.4.0-2.1.el7.x86_64 on RHEL7.3 Beta(Maipo)

ipa.ipaserver.install.ipa_winsync_migrate.WinsyncMigrate: DEBUG: Migrated: user4@PNE.QE
ipa.ipaserver.install.ipa_winsync_migrate.WinsyncMigrate: WARNING: Migration completed. Please note that if PassSync was configured on the given Active Directory server, it needs to be manually removed, otherwise it may try to reset password for accounts that are no longer existent.
ipa.ipaserver.install.ipa_winsync_migrate.WinsyncMigrate: INFO: The ipa-winsync-migrate command was successful
Comment 9 errata-xmlrpc 2016-11-04 01:51:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html

Note You need to log in before you can comment on or make changes to this bug.