Bug 1313806 - Routing errors due to missing graphics/fonts on navigating smart-proxy page
Routing errors due to missing graphics/fonts on navigating smart-proxy page
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: GA
: 6.2
Assigned To: Ondřej Pražák
Kedar Bidarkar
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 06:46 EST by Sachin Ghai
Modified: 2016-07-27 07:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:25:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
firebug raises 404 while fetching missing graphics/fonts (122.20 KB, image/png)
2016-03-02 06:48 EST, Sachin Ghai
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14028 None None None 2016-04-22 11:43 EDT
Foreman Issue Tracker 14393 None None None 2016-04-26 13:07 EDT

  None (edit)
Description Sachin Ghai 2016-03-02 06:46:57 EST
Description of problem: On navigating the smart-proxy page, production.log filled with following routing errors:


2016-03-02 12:34:01 [app] [I] Started GET "/assets/fonts/bootstrap/glyphicons-halflings-regular.woff" for 10.65.193.200 at 2016-03-02 12:34:01 +0100
2016-03-02 12:34:01 [app] [F] 
 | ActionController::RoutingError (No route matches [GET] "/assets/fonts/bootstrap/glyphicons-halflings-regular.woff"):
 |   actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'
 |   actionpack (4.1.5) lib/action_dispatch/middleware/show_exceptions.rb:30:in `call'


2016-03-02 12:34:01 [app] [I] Started GET "/assets/sort_asc.png" for 10.65.193.200 at 2016-03-02 12:34:01 +0100
2016-03-02 12:34:01 [app] [F] 
 | ActionController::RoutingError (No route matches [GET] "/assets/sort_asc.png"):
 |   actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'
 |   actionpack (4.1.5) lib/action_dispatch/middleware/show_exceptions.rb:30:in `call'
 |   railties (4.1.5) lib/rails/rack/logger.rb:38:in `call_app'
 

2016-03-02 12:34:01 [app] [I] Started GET "/assets/sort_both.png" for 10.65.193.200 at 2016-03-02 12:34:01 +0100
2016-03-02 12:34:01 [app] [F] 
 | ActionController::RoutingError (No route matches [GET] "/assets/sort_both.png"):
 |   actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'
 |   actionpack (4.1.5) lib/action_dispatch/middleware/show_exceptions.rb:30:in `call'
 |   railties (4.1.5) lib/rails/rack/logger.rb:38:in `call_app'
 

2016-03-02 12:34:01 [app] [I] Started GET "/assets/fonts/bootstrap/glyphicons-halflings-regular.ttf" for 10.65.193.200 at 2016-03-02 12:34:01 +0100
2016-03-02 12:34:01 [app] [F] 
 | ActionController::RoutingError (No route matches [GET] "/assets/fonts/bootstrap/glyphicons-halflings-regular.ttf"):
 |   actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'
 |   actionpack (4.1.5) lib/action_dispatch/middleware/show_exceptions.rb:30:in `call'
 


Version-Release number of selected component (if applicable):
Satellite 6.2 snap1

How reproducible:
always

Steps to Reproduce:
1. Navigate to Infrastructure -> smart-proxies ->select default proxy
2.
3.

Actual results:
routing errors due to missing graphics and images 

Expected results:
on navigating 'smart-proxies' no error should be thrown in production.log

Additional info:
Comment 1 Sachin Ghai 2016-03-02 06:48 EST
Created attachment 1132275 [details]
firebug raises 404 while fetching missing graphics/fonts
Comment 3 Brad Buckingham 2016-03-02 14:16:50 EST
Created redmine issue http://projects.theforeman.org/issues/14028 from this bug
Comment 4 Bryan Kearney 2016-03-02 16:06:28 EST
Upstream bug component is Provisioning
Comment 5 Bryan Kearney 2016-03-03 04:06:36 EST
Upstream bug component is WebUI
Comment 6 Bryan Kearney 2016-03-03 08:06:32 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/14028 has been closed
-------------
Dominic Cleal
Applied in changeset commit:3ae0173ec97a4688d6d67928e3b72bbfe208b91e.
Comment 7 Kedar Bidarkar 2016-03-22 10:47:25 EDT
This issue is still seen with sat62-snap4-compose1


016-03-22 10:45:52 [app] [F] 
 | ActionController::RoutingError (No route matches [GET] "/assets/fonts/bootstrap/glyphicons-halflings-regular.ttf"):
 |   actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'
 |   actionpack (4.1.5) lib/action_dispatch/middleware/show_exceptions.rb:30:in `call'
 |   railties (4.1.5) lib/rails/rack/logger.rb:38:in `call_app'
 |   railties (4.1.5) lib/rails/rack/logger.rb:22:in `call'
 |   actionpack (4.1.5) lib/action_dispatch/middleware/request_id.rb:21:in `call'
 |   rack (1.5.2) lib/rack/methodoverride.rb:21:in `call'
 |   rack (1.5.2) lib/rack/runtime.rb:17:in `call'
 |   activesupport (4.1.5) lib/active_support/cache/strategy/local_cache_middleware.rb:26:in `call'
 |   actionpack (4.1.5) lib/action_dispatch/middleware/static.rb:64:in `call'
 |   rack (1.5.2) lib/rack/sendfile.rb:112:in `call'
 |   railties (4.1.5) lib/rails/engine.rb:514:in `call'
 |   railties (4.1.5) lib/rails/application.rb:144:in `call'
 |   railties (4.1.5) lib/rails/railtie.rb:194:in `public_send'
 |   railties (4.1.5) lib/rails/railtie.rb:194:in `method_missing'
 |   rack (1.5.2) lib/rack/builder.rb:138:in `call'
 |   rack (1.5.2) lib/rack/urlmap.rb:65:in `block in call'
 |   rack (1.5.2) lib/rack/urlmap.rb:50:in `each'
 |   rack (1.5.2) lib/rack/urlmap.rb:50:in `call'
 |   /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/rack/thread_handler_extension.rb:77:in `process_request'
 |   /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:140:in `accept_and_process_next_request'
 |   /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:108:in `main_loop'
 |   /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler.rb:441:in `block (3 levels) in start_threads'
 |   logging (1.8.2) lib/logging/diagnostic_context.rb:323:in `call'
 |   logging (1.8.2) lib/logging/diagnostic_context.rb:323:in `block in create_with_logging_context'
 | 
 |
Comment 9 Ondřej Pražák 2016-04-07 04:36:46 EDT
There has been another attempt to fix this with: http://projects.theforeman.org/issues/14393, which is already merged and closed
Comment 10 Bryan Kearney 2016-04-25 14:11:53 EDT
Connecting redmine issue http://projects.theforeman.org/issues/14393 from this bug
Comment 11 Bryan Kearney 2016-04-25 16:08:48 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14393 has been closed
-------------
Ondřej Pražák
Applied in changeset commit:8b9d6f4a20bc10d452fb742bb0d358fd23b5a429.
Comment 12 Kedar Bidarkar 2016-05-11 13:14:18 EDT
Routing Errors are no longer seen.

VERIFIED With sat62-snap10.1
Comment 13 Bryan Kearney 2016-07-27 07:25:17 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.