Bug 1313838 - Tiering as separate process and in v status moving tier task to tier process
Tiering as separate process and in v status moving tier task to tier process
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: hari gowtham
bugs@gluster.org
: FutureFeature
Depends On:
Blocks: glusterfs-3.9.0
  Show dependency treegraph
 
Reported: 2016-03-02 07:31 EST by hari gowtham
Modified: 2017-03-06 12:20 EST (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.10.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-06 12:20:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hari gowtham 2016-03-02 07:31:53 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2016-03-02 07:34:23 EST
REVIEW: http://review.gluster.org/13365 (tier : Tier as a separate process) posted (#3) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Vijay Bellur 2016-03-17 07:33:10 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a separate process) posted (#4) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 3 Vijay Bellur 2016-03-18 01:09:22 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a separate process) posted (#5) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 4 Vijay Bellur 2016-03-18 02:59:27 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a separate process) posted (#6) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 5 Vijay Bellur 2016-03-21 06:16:27 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a separate process) posted (#7) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 6 Mike McCune 2016-03-28 18:40:27 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 7 Vijay Bellur 2016-04-14 08:49:25 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a separate process) posted (#8) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 8 Vijay Bellur 2016-06-01 02:10:54 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a separate process) posted (#9) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 9 Vijay Bellur 2016-06-08 03:27:45 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a separate process) posted (#10) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 10 Vijay Bellur 2016-06-09 09:33:04 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a separate process) posted (#11) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 11 Vijay Bellur 2016-06-10 01:52:59 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a separate process) posted (#12) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 12 Vijay Bellur 2016-06-28 06:12:14 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a separate process) posted (#13) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 13 Vijay Bellur 2016-06-30 08:31:42 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a separate process) posted (#14) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 14 Vijay Bellur 2016-07-05 04:09:38 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a separate process) posted (#15) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 15 Vijay Bellur 2016-07-18 11:08:03 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#16) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 16 Vijay Bellur 2016-08-16 04:47:04 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#17) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 17 Vijay Bellur 2016-08-18 08:35:46 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#18) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 18 Worker Ant 2016-08-24 02:33:01 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#19) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 19 Worker Ant 2016-09-01 09:39:06 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#20) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 20 Worker Ant 2016-09-07 07:47:38 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#21) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 21 Worker Ant 2016-09-13 03:05:28 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#22) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 22 Worker Ant 2016-09-13 03:24:11 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#23) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 23 Worker Ant 2016-09-14 02:38:33 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#24) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 24 Worker Ant 2016-09-15 02:36:44 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#25) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 25 Worker Ant 2016-09-16 05:04:53 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#27) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 26 Worker Ant 2016-09-19 08:06:41 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#28) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 27 Worker Ant 2016-09-20 02:35:10 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#29) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 28 Worker Ant 2016-09-20 04:56:37 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#30) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 29 Worker Ant 2016-09-20 06:08:17 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#31) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 30 Worker Ant 2016-09-20 06:53:09 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#32) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 31 Worker Ant 2016-09-22 07:54:53 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#33) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 32 Worker Ant 2016-09-30 07:30:14 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#34) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 33 Worker Ant 2016-10-12 08:10:12 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#35) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 34 Worker Ant 2016-10-13 06:08:34 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#36) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 35 Worker Ant 2016-10-20 08:47:00 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#37) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 36 Worker Ant 2016-10-24 03:06:51 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#38) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 37 Worker Ant 2016-10-26 08:14:06 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#39) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 38 Worker Ant 2016-10-27 03:17:22 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#40) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 39 Worker Ant 2016-11-03 03:16:46 EDT
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#41) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 40 Worker Ant 2016-11-16 05:10:56 EST
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#42) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 41 Worker Ant 2016-11-21 01:02:14 EST
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#43) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 42 Worker Ant 2016-12-06 05:48:40 EST
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#44) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 43 Worker Ant 2016-12-07 07:51:58 EST
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#45) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 44 Worker Ant 2016-12-21 03:50:01 EST
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#46) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 45 Worker Ant 2016-12-26 01:42:17 EST
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#47) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 46 Worker Ant 2016-12-29 01:51:51 EST
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#48) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 47 Worker Ant 2016-12-29 03:58:56 EST
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#49) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 48 Worker Ant 2017-01-03 04:49:21 EST
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#50) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 49 Worker Ant 2017-01-11 04:46:17 EST
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#51) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 50 Worker Ant 2017-01-12 04:12:03 EST
REVIEW: http://review.gluster.org/13365 (tier : Tier as a service) posted (#52) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 51 Worker Ant 2017-01-16 23:49:54 EST
COMMIT: http://review.gluster.org/13365 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 3263d1c4f4b7efd1a018c17e1ba4dd9245094f48
Author: hari gowtham <hgowtham@redhat.com>
Date:   Tue Jul 12 16:40:28 2016 +0530

    tier : Tier as a service
    
    tierd is implemented by separating from rebalance process.
    
    The commands affected:
    
    1) Attach tier will trigger this process instead of old one
    2) tier start and tier start force will also trigger this process.
    3) volume status [tier] will show tier daemon as a process instead
    of task and normal tier status and tier detach status works.
    4) tier stop implemented.
    5) detach tier implemented separately along with new detach tier
    status
    6) volume tier volname status will work using the changes.
    7) volume set works
    
    This patch has separated the tier translator from the legacy
    DHT rebalance code. It now sends the RPCs from the CLI
    to glusterd separate to the DHT rebalance code.
    The daemon is now a service, similar to the snapshot daemon,
    and can be viewed using the volume status command.
    
    The code for the validation and commit phase are the same
    as the earlier tier validation code in DHT rebalance.
    
    The “brickop” phase has been changed so that the status
    command can use this framework.
    
    The service management framework is now used.
    DHT rebalance does not use this framework.
    
    This service framework takes care of :
    
    *) spawning the daemon, killing it and other such processes.
    *) volume set options , which are written on the volfile.
    *) restart and reconfigure functions. Restart is to restart
    the daemon at two points
            1)after gluster goes down and comes up.
            2) to stop detach tier.
    *) reconfigure is used to make immediate volfile changes.
    By doing this, we don’t restart the daemon.
    it has the code to rewrite the volfile for topological
    changes too (which comes into place during add and remove brick).
    
    With this patch the log, pid, and volfile are separated
    and put into respective directories.
    
    Change-Id: I3681d0d66894714b55aa02ca2a30ac000362a399
    BUG: 1313838
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/13365
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 52 Shyamsundar 2017-03-06 12:20:01 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.