Bug 1313846 - selecting the Oscap_Proxy throws TypeError as seen from Firebug
selecting the Oscap_Proxy throws TypeError as seen from Firebug
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: SCAP Plugin (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: GA
: --
Assigned To: Shlomi Zadok
Sanket Jagtap
http://projects.theforeman.org/issues...
: Triaged
: 1337868 (view as bug list)
Depends On:
Blocks: 1337868
  Show dependency treegraph
 
Reported: 2016-03-02 07:41 EST by Kedar Bidarkar
Modified: 2016-07-27 07:18 EDT (History)
3 users (show)

See Also:
Fixed In Version: rubygem-foreman_openscap-0.5.3.13-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:18:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14561 None None None 2016-04-22 11:05 EDT

  None (edit)
Description Kedar Bidarkar 2016-03-02 07:41:36 EST
Description of problem:

selecting the Oscap_Proxy host throws TypeError as seen from Firebug

Firebug shows the below error when  selecting "Openscap proxy":

TypeError: $(...).indicator_show is not a function
	

...+o:t+"&host_id="+o,toggleErrorText(""),$(e).indicator_show(),$.ajax({type:"post"...


No issues seen in "/var/log/foreman/production.log"

Version-Release number of selected component (if applicable):
Sat6.2.0-Beta-SNAP1

How reproducible:


Steps to Reproduce:
1. configure OSCAP plugin and restart services
2. create a "New Host" and specify the "oscap proxy" to note the above TypeError in FireBug.
3.

Actual results:
Issues seen with selecting the "oscap proxy"

Expected results:
Firebug should throw no issues while selecting the "oscap proxy".

Additional info:
Comment 4 Kedar Bidarkar 2016-04-06 07:57:04 EDT
Selecting OSCAP_Proxy still has few issues with Javascript as seen below.

These issue are seen both in FF and chrome.


POST https://abc.redhat.com/hosts/openscap_proxy_changed 404 (Not Found)send @ application-8c003690572a3ba05aa2be14d1d396a74808b692604127df092aa9c2ae46f324.js:27st.extend.ajax @ application-8c003690572a3ba05aa2be14d1d396a74808b692604127df092aa9c2ae46f324.js:27updateOpenscapProxy @ openscap_proxy-3b847fe7ed27cdc7b6678b9fb3775af368520aa8615c6f83b5958e761dc3f857.js:1onchange @ new:371st.event.trigger @ application-8c003690572a3ba05aa2be14d1d396a74808b692604127df092aa9c2ae46f324.js:26(anonymous function) @ application-8c003690572a3ba05aa2be14d1d396a74808b692604127df092aa9c2ae46f324.js:26st.extend.each @ application-8c003690572a3ba05aa2be14d1d396a74808b692604127df092aa9c2ae46f324.js:15st.fn.st.each @ application-8c003690572a3ba05aa2be14d1d396a74808b692604127df092aa9c2ae46f324.js:15st.fn.extend.trigger @ application-8c003690572a3ba05aa2be14d1d396a74808b692604127df092aa9c2ae46f324.js:26E.triggerChange @ application-8c003690572a3ba05aa2be14d1d396a74808b692604127df092aa9c2ae46f324.js:604E.onSelect @ application-8c003690572a3ba05aa2be14d1d396a74808b692604127df092aa9c2ae46f324.js:605E.selectHighlighted @ application-8c003690572a3ba05aa2be14d1d396a74808b692604127df092aa9c2ae46f324.js:604(anonymous function) @ application-8c003690572a3ba05aa2be14d1d396a74808b692604127df092aa9c2ae46f324.js:604(anonymous function) @ application-8c003690572a3ba05aa2be14d1d396a74808b692604127df092aa9c2ae46f324.js:604st.event.dispatch @ application-8c003690572a3ba05aa2be14d1d396a74808b692604127df092aa9c2ae46f324.js:26g.handle @ application-8c003690572a3ba05aa2be14d1d396a74808b692604127df092aa9c2ae46f324.js:25


I think this is more easily reproducible if we have 2 OSCAP proxies and not just one to choose from.
Comment 6 Shlomi Zadok 2016-04-10 06:26:40 EDT
Created redmine issue http://projects.theforeman.org/issues/14561 from this bug
Comment 9 Bryan Kearney 2016-05-20 10:12:14 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14561 has been closed
Comment 10 Kedar Bidarkar 2016-05-23 08:36:49 EDT
*** Bug 1337868 has been marked as a duplicate of this bug. ***
Comment 13 Sanket Jagtap 2016-06-21 05:44:28 EDT
Build : satellite 6.2 Snap 16.0

Verified , no TypeError while selecting OSCAP proxy
Comment 14 Bryan Kearney 2016-07-27 07:18:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.