Bug 1313851 - Unckecking override checkbox in smart class parameters effects other checkboxes
Unckecking override checkbox in smart class parameters effects other checkboxes
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.0.4
Unspecified Unspecified
unspecified Severity medium (vote)
: Beta
: --
Assigned To: orabin
Jitendra Yejare
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 07:54 EST by Tomer Brisker
Modified: 2016-07-27 05:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:03:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13976 None None None 2016-04-22 12:05 EDT

  None (edit)
Description Tomer Brisker 2016-03-02 07:54:36 EST
When unchecking the override checkbox the matchers and validators are saved so when it's checked again they are all there.
All the checkboxes on the form (use puppet default, hidden value, required) are unchecked (because they are disabled and don't send their value).
This should be consistent - we either save the state of the parameter or we remove everything.
Comment 1 Tomer Brisker 2016-03-02 07:54:39 EST
Created from redmine issue http://projects.theforeman.org/issues/13976
Comment 2 Tomer Brisker 2016-03-02 07:54:43 EST
Upstream bug assigned to orabin@redhat.com
Comment 3 orabin 2016-03-02 08:01:48 EST
upstream bug is merged
Comment 4 Bryan Kearney 2016-03-02 08:11:43 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13976 has been closed
-------------
Ori Rabin
Applied in changeset commit:dba5afe0f39748ea8dafad88a7da046a6aab5c9a.
Comment 7 Jitendra Yejare 2016-04-15 07:06:26 EDT
Verified this in Sat 6.2 snap 8.1

I see that on unchecking the override parameter, all other entities(checkboxes, values) state is saved.

I am agree with this update and its one of the solution suggested in Description of bug.

So moving this to Verifed.
Comment 9 errata-xmlrpc 2016-07-27 05:03:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.