Bug 1313858 - unable to create new subnet
Summary: unable to create new subnet
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Marek Hulan
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-02 13:11 UTC by Kedar Bidarkar
Modified: 2019-09-26 14:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:04:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 13711 Normal Closed Can't create new subnet with domain 2020-06-04 18:54:47 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Kedar Bidarkar 2016-03-02 13:11:46 UTC
Description of problem:


Currently we are unable to create subnets from the UI using the "Infrastructre" --> "subnets"--> "new subnet" button.

2016-03-02 13:13:31 [app] [I] Failed to save: Subnet domains is invalid, Subnet domains is invalid
2016-03-02 13:13:31 [app] [I]   Rendered subnets/_fields.html.erb (19.8ms)
2016-03-02 13:13:31 [app] [I]   Rendered common/_edit_habtm.html.erb (39.1ms)
2016-03-02 13:13:31 [app] [I]   Rendered taxonomies/_loc_org_tabs.html.erb (20.5ms)
2016-03-02 13:13:31 [app] [I]   Rendered subnets/_form.html.erb (216.0ms)
2016-03-02 13:13:31 [app] [I]   Rendered subnets/new.html.erb (218.0ms)
2016-03-02 13:13:31 [app] [I] Completed 200 OK in 454ms (Views: 203.0ms | ActiveRecord: 37.6ms)



Version-Release number of selected component (if applicable):
Sat6.2.0-Beta-SNAP1

How reproducible:


Steps to Reproduce:
1. create a new subnet with valid values
2.
3.

Actual results:
Unable to create new subnet via "Infrastructre" --> "subnets"--> "new subnet" button.

Expected results:
Should be able to create new subnet via "Infrastructre" --> "subnets"--> "new subnet" button.

Additional info:

Workaround: Currently using the "import subnet" button found on the smart-proxy dropdown helps identify subnet and create one for us.

Comment 2 Brad Buckingham 2016-03-02 18:40:32 UTC
Config: satellite-6.2.0-4.beta.el7sat.noarch

I was able to create a subnet with:

name: test
network address: 192.168.121.0
network mask: 255.255.255
domain: example.com


I am, however, unable to delete it in the UI.  Doing so, results in an error indicating:

Error: test (192.168.121.0/24) is used by example.com

Comment 3 Marek Hulan 2016-03-03 07:35:22 UTC
This is bug, you can't select domains on new subnet creation. If you don't choose any domain, it works. After it's persisted you can edit the subnet and assign domain. There's already a PR waiting to be re-reviewed and merged.

Comment 4 Marek Hulan 2016-03-03 07:36:30 UTC
And just for the record, you can't delete subnet if it's used by some host so the error that Brad mentions is expected behavior. You'd have to disassociate the subnet from host prior subnet deletion.

Comment 5 Bryan Kearney 2016-03-03 17:09:37 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/13711 has been closed
-------------
Anonymous
Applied in changeset commit:46eec8ba4163a8f237b3189f43d2f873a2267288.

Comment 6 Kedar Bidarkar 2016-03-10 13:31:05 UTC
we can now create the subnet ( with domain info) at the time of creation itself.

VERIFIED with Sat6.2-SNAP3-compose1

Comment 9 errata-xmlrpc 2016-07-27 09:04:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.