Bug 131388 - updating hal system locks up
updating hal system locks up
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-31 16:43 EDT by Joseph Harnish
Modified: 2013-03-05 22:41 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-12 12:45:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Harnish 2004-08-31 16:43:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
Gecko/20040803 Firefox/0.8

Description of problem:
When I run an update and there is a new package of hal it installs all
the packages and when it is working on the finishing up it freezes my
workstation.  I have to manually reboot.  Now when I do a 'rpm -qa |
sort' I see some of the packages it was updating with hal duplicated.  

right now I see:

xmms-1.2.10-4 
xmms-1.2.10-6
xmms-devel-1.2.10-4
xmms-devel-1.2.10-6

etc.  


Version-Release number of selected component (if applicable):
rpm-4.3.20-10

How reproducible:
Always

Steps to Reproduce:
1. yum update
2. when there is a hal package 
3. hard reboot
    

Actual Results:  system locks up.

Expected Results:  packages updated and old packages removed.

Additional info:

I don't think it has to do with yum.
Comment 1 Jeff Johnson 2004-09-02 11:49:05 EDT
Try downloading and installing the hal package with -Uvv.

I suspect that you will find that the hang
is occuring when the haldaemon process is restarted
during package install. If so, that is a hal, not rpm/yum,
problem.

Is your machine hanging when haldaemon is restarted?
Comment 2 Joseph Harnish 2004-09-02 14:28:34 EDT
I will try this.  It may take a little bit after the last update.  
But from what I saw with YUM it died when it was running the post 
script.  Once my system is back online I will test this.
Comment 3 Jeff Johnson 2004-09-02 18:49:59 EDT
The daemon restart is what is done in %post. Reassigning to hal ...
Comment 4 David Zeuthen 2004-09-02 19:25:34 EDT
Did you have hal-0.2.97.cvs20040819 installed before the upgrade?

If yes, you need to manually kill the haldaemon before upgrading.
'pkill hald' as root will achieve this. For more information see
http://www.redhat.com/archives/fedora-test-list/2004-August/msg00785.html
as this is a known issue with that version.
Comment 5 David Zeuthen 2004-09-02 19:33:03 EDT
Btw, one way to resolve this may be to kill the hal daemon, erase all
duplicates of the hal package (so you only have one left) and manually
upgrade to the latest version of hal which 0.2.97.cvs20040901-1.
Comment 6 David Zeuthen 2004-09-12 12:45:37 EDT
Since we haven't heard anything back for more than a week and I'm sure
that the issues were caused by the bug mentioned that is already fixed
I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.