Bug 1313881 - [networking] Adapt to the lack of CFG property of NICS in VDSM netinfo
[networking] Adapt to the lack of CFG property of NICS in VDSM netinfo
Status: CLOSED CURRENTRELEASE
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Network (Show other bugs)
2.0.0
Unspecified Unspecified
high Severity high (vote)
: ovirt-4.1.0-alpha
: 2.1.0
Assigned To: Simone Tiraboschi
Meni Yakove
: CodeChange
: 1347438 (view as bug list)
Depends On:
Blocks: 1313872
  Show dependency treegraph
 
Reported: 2016-03-02 09:22 EST by Simone Tiraboschi
Modified: 2017-05-11 05:29 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-27 05:37:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
rule-engine: planning_ack+
sbonazzo: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 58931 master MERGED network: avoid using interface cfg entries 2016-09-12 12:27 EDT

  None (edit)
Description Simone Tiraboschi 2016-03-02 09:22:05 EST
Description of problem:
CFG property of NICS will be removed from VDSM netinfo. Adapt hosted-engine-setup code according to that.
Comment 1 Sandro Bonazzola 2016-03-09 09:49:51 EST
dan, can you please advise on what should be used instead of netinfo.CachingNetInfo ?
Comment 2 Dan Kenigsberg 2016-03-09 09:52:48 EST
We have seen that it is dangerous to depend on vdsm internal module structure. Vdsm has a public API, and only it should be used by components outside the Vdsm git tree. Vdsm has no test nor a commitment to keep internal functions, so please call getVdsCaps and parse it, just like Engine does.
Comment 3 Sandro Bonazzola 2016-05-02 06:04:43 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 4 Yaniv Lavi 2016-05-23 09:19:29 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 5 Yaniv Lavi 2016-05-23 09:23:13 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 6 Yaniv Lavi 2016-06-02 04:17:13 EDT
What is the action item on this bug?
Comment 7 Simone Tiraboschi 2016-06-09 13:30:47 EDT
In vdsm from branch 40, netinfo still contains the cfg element.

It has been recently removed on master: https://gerrit.ovirt.org/#/c/58226
but it sill requires some work to report otherwise missing information: https://gerrit.ovirt.org/#/c/58351/6
Comment 8 Douglas Schilling Landgraf 2016-06-17 12:41:13 EDT
*** Bug 1347438 has been marked as a duplicate of this bug. ***
Comment 9 Yaniv Lavi 2016-09-08 04:30:51 EDT
Can you add the ticket for adding the missing API info?
Comment 10 Dan Kenigsberg 2016-09-08 05:46:51 EDT
Sorry, Yaniv, I do not understand your request. could you rephrase it?
Comment 11 Simone Tiraboschi 2016-09-08 05:50:01 EDT
It was https://gerrit.ovirt.org/#/c/58351 but I see that now it's in.
Comment 12 Michael Burman 2017-04-04 07:05:13 EDT
Hi Simone, 

Please explain how exactly this should be tested and verified? I see it has CodeChange Keywords. 

I don't see the cfg property on vdsCaps anymore, is it good enough?
If the change is on the hosted-engine code, then please move it to verified as i'm not sure what exactly should be tested here.
Comment 13 Dan Kenigsberg 2017-04-04 07:32:24 EDT
QE needs to verify that all network-related hosted-engine flows still work.
There should be no functional change visible to the user.
Comment 14 Michael Burman 2017-04-04 10:31:19 EDT
Tested with ovirt-hosted-engine-setup-2.1.0.5-1.el7ev.noarch

Note You need to log in before you can comment on or make changes to this bug.