Bug 1313893 - disable cinder logging in /var/log/messages on the controller node
disable cinder logging in /var/log/messages on the controller node
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
8.0 (Liberty)
All Linux
low Severity medium
: ga
: 8.0 (Liberty)
Assigned To: Eric Harney
lkuchlan
: Reopened
Depends On: 1306651
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 10:04 EST by Eric Harney
Modified: 2016-04-26 15:59 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-cinder-7.0.1-7.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1306651
Environment:
Last Closed: 2016-04-07 17:32:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 284828 None None None 2016-03-02 10:04 EST

  None (edit)
Comment 3 lkuchlan 2016-03-21 06:33:18 EDT
Tested using:
python-cinder-7.0.1-7.el7ost.noarch
python-cinderclient-1.5.0-1.el7ost.noarch
openstack-cinder-7.0.1-7.el7ost.noarch

Verification flow:

[root@overcloud-controller-0 ~]# cat /etc/cinder/cinder.conf | grep '^use_syslog\|^use_stderr'
use_syslog = false
use_stderr = false

* Restart service
[root@overcloud-controller-0 ~]# pcs resource restart openstack-cinder-api-clone

* Run api call
[stack@undercloud ~]$ cinder list

[root@overcloud-controller-0 ~]# tailf /var/log/messages | grep -i cinder

Results:
No logs of Cinder in `/var/log/messages`
Comment 4 errata-xmlrpc 2016-04-07 17:32:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.