Bug 1313894 - nova start fails in case flavor is deleted and archived in OSP 6
nova start fails in case flavor is deleted and archived in OSP 6
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
6.0 (Juno)
All Linux
high Severity high
: ---
: 6.0 (Juno)
Assigned To: Eoghan Glynn
nlevinki
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 10:05 EST by Martin Tessun
Modified: 2016-03-04 11:00 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-04 10:29:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Tessun 2016-03-02 10:05:35 EST
Description of problem:
In case a stopped instance is started after the flavor of it has been deleted and archived, the instance does not start up.

Version-Release number of selected component (if applicable):
OSP 6

How reproducible:
always

Steps to Reproduce:
1. Create a flavor
2. Create an instance based on the flavor
3. Delete the flavor
4. Stop the instance
5. Start the instance
6. Archive the flavor
7. Stop the instance
8. Start the instance

Actual results:
The instance does not start in Step (8)

Expected results:
The instance should still start.

Additional info:
This scenario does work if OSP 7 is used.
Comment 2 Dan Smith 2016-03-03 10:11:24 EST
OSP7 specifically addresses this by putting flavor data into the instance record itself. That was a ton of work and definitely not backportable to OSP7. In all time before OSP7, if you actually hard delete the flavor from the database (as you're doing by a delete+archive) then the instance can't start because we have lost vital data about it.

The solution is to never purge flavors in OSP6 and previous.

Note You need to log in before you can comment on or make changes to this bug.