Bug 131396 - Missing licensing information in unarj package
Missing licensing information in unarj package
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: unarj (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Lon Hohberger
: EasyFix
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-31 18:43 EDT by Ville Skyttä
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-13 17:38:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2004-08-31 18:43:31 EDT
The unarj package does not include various *.txt files from inside the
upstream archive.  Of these, unarj.txt contains licensing information.
 I'd suggest including that and technote.txt in the package.

OTOH, FYI: the license of unarj sounds quite a bit like the one of
pine to me, and pine was removed from Fedora Core due to legal issues.
Comment 1 Ville Skyttä 2004-09-01 02:33:18 EDT
In addition to unarj.txt, run unarj without arguments to see more
license terms.
Comment 2 Barry K. Nathan 2004-09-01 08:17:44 EDT
Wow, that's a rather odd license: One of the conditions for commercial
redistribution seems to be that the "...user must fully understand
that UNARJ does not have the long usage history that ARJ does." I
certainly didn't "fully understand" that before reading the license.
:( I guess you would need to make the thing display a warning message
each time it's run or something. Although, such a warning message
would be almost an advertisement for the commercial ARJ.

I'm not sure unarj can really be called "open source".


(If it can be, then I have two other things to mention:
(a) The latest version is 2.65, not 2.63a
(b) ARJ archives are rare enough these days (IMO) that this package
probably belongs in Extras, not Core.

If the package isn't going to be dropped completely, then I guess I
could file another bug for (a) and mention (b) on the mailing lists.)
Comment 6 Ville Skyttä 2004-09-01 11:25:33 EDT
FWIW, I already have an update to 2.65 available from
http://cachalot.mine.nu/2/SRPMS.lvn/ .  My guess is that this will be
removed from Core, and livna.org would be the best new home for it :)

* Wed Sep  1 2004 Ville Skyttä <ville.skytta at iki.fi> - 2.65-0.lvn.1
- Update to 2.65.
- Add technote.txt and unarj.txt to docs.
- Honor $RPM_OPT_FLAGS.

By the way, the 2.65 source is shipped as a "self-extracting" .exe,
which can be unpacked on Linux using... unarj :P
Comment 7 Mike A. Harris 2004-09-01 11:40:19 EDT
ARJ archives were popular on MSDOS about 15 years ago, but I don't
really see the usefullness of them on a modern Linux system.  This
is the type of functionality I'd expect us to remove and stuff in
Fedora Extras, or if the license sucks, to just dump it.  The
impact on users is likely very minimal.
Comment 8 Mike A. Harris 2004-09-01 11:41:26 EDT
unrar would be more useful to have, and I think it might even
qualify as open source ;)
Comment 9 Lon Hohberger 2004-09-01 12:42:45 EDT
I'll take unrar if we remove unarj from the distro.  I've actually had
to use unrar in the past decade.
Comment 11 Ville Skyttä 2004-09-01 14:53:10 EDT
I think adding unrar would be nice.  Coincidentally, I've been
maintaining an unrar rpm for about 18 months now, feel free to grab it:
http://rpm.livna.org/fedora/2/i386/SRPMS.stable/unrar-3.4.1-0.lvn.1.2.src.rpm
Comment 14 Lon Hohberger 2004-09-13 17:38:06 EDT
Package has been removed from Fedora Core 3.

Note You need to log in before you can comment on or make changes to this bug.