Bug 131398 - dosfsck, mkdosfs conflicting results
dosfsck, mkdosfs conflicting results
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: dosfstools (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-31 19:17 EDT by Mace Moneta
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-11 05:00:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mace Moneta 2004-08-31 19:17:45 EDT
Description of problem:

dosfsck reports that newly created filesystem (mkdosfs) is in error. 
If dosfsck is unusable, it should be removed or disabled.  If mkdosfs
is creating bad filesystems, it should be removed or disabled.

Version-Release number of selected component (if applicable):

dosfstools-2.8-12

How reproducible:

Create a dos filesystem on a device, then check it.

Steps to Reproduce:
1.mkdosfs a partition
2.dosfsck the partition
3.observe error
  
Actual results:

Error

Expected results:

No error

Additional info:

Sample run:

# mkdosfs /dev/sdf2
mkdosfs 2.8 (28 Feb 2001)

# dosfsck /dev/sdf2
dosfsck 2.8, 28 Feb 2001, FAT32, LFN
Warning: FAT32 support is still ALPHA.
Cluster 608765 out of range (4870146 > 1217333). Setting to EOF.
/
  Contains a free cluster (2). Assuming EOF.
FAT32 root dir starts with a bad cluster!
Comment 1 Barry K. Nathan 2004-09-01 07:29:23 EDT
If you happen to have a copy of the appropriate software, you could
try scanning a mkdosfs'd filesystem with chkdsk (Win2K/XP) or scandisk
(Win98/ME/MS-DOS 7.x). Or you could use Windows or MS-DOS 7.x to
format a filesystem, then check it with dosfsck.

BTW, it looks like your bug report fails to specify how reproducible
the bug is.
Comment 2 Mace Moneta 2004-09-02 00:35:13 EDT
Sorry, it's 100% reproducible (I was testing with a 20GB firewire dive).  

I don't have access to a real Windows system that can access the
Firewire drive (the reason I was using mkdosfs/dosfsck), so I can't
check to see which is in error.

Note You need to log in before you can comment on or make changes to this bug.