This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1314070 - Segfault with basic use of libproxy-python
Segfault with basic use of libproxy-python
Status: CLOSED DUPLICATE of bug 1296817
Product: Fedora
Classification: Fedora
Component: libproxy (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David King
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 15:07 EST by F Wolff
Modified: 2016-03-03 04:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-03 04:00:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description F Wolff 2016-03-02 15:07:27 EST
Description of problem:
I'm testing a python application on Fedora 23 that uses libproxy-python. It has a segfault early when using libproxy.


Version-Release number of selected component (if applicable):
0.4.11-12


Steps to Reproduce:
Minimal example:
python -c "import libproxy; print libproxy.ProxyFactory().getProxies('http://fedoraproject.org')"

Actual results:
Segmentation fault (core dumped)

Expected results:
['direct://']
(or whatever the proxy configuration is)

Additional info:
$ rpm -qa|grep libproxy
libproxy-0.4.11-12.fc23.x86_64
libproxy-gnome-0.4.11-12.fc23.x86_64
libproxy-bin-0.4.11-12.fc23.x86_64
libproxy-python-0.4.11-12.fc23.noarch

The commandline tool from libproxy-bin ("proxy") works without crash:
$ proxy http://fedoraproject.org
direct://
Comment 1 David King 2016-03-03 04:00:39 EST
This looks like https://code.google.com/archive/p/libproxy/issues/146 for which there is no fix (yet). Additionally, this is a duplicate of bug 1296817 (which also has a stack trace).

*** This bug has been marked as a duplicate of bug 1296817 ***

Note You need to log in before you can comment on or make changes to this bug.