Bug 1314098 - virtual machine manager should include Ceph RBD option when creating a new vm
virtual machine manager should include Ceph RBD option when creating a new vm
Status: CLOSED DUPLICATE of bug 1240608
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Pavel Hrdina
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 17:48 EST by Vasu Kulkarni
Modified: 2016-06-07 04:58 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-07 04:58:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vasu Kulkarni 2016-03-02 17:48:05 EST
Description of problem:

Create new Virtual machine should include the option to specify existing Ceph RBD image, currently there is no such option and one has to define xml to do this.

If the qemu is already an existing ceph client, it could just list the available rbd images one can use to create or boot a new vm. 

Version-Release number of selected component (if applicable):

1.1.0

How reproducible:
N/A
Comment 2 Pavel Hrdina 2016-06-07 04:58:56 EDT
Virt-manager uses storage pools for storage images.  To use Ceph you have to create a RBD storage pool which isn't currently supported.  There is an existing bug to add support for RBD storage pools so closing as duplicate of that bug.

*** This bug has been marked as a duplicate of bug 1240608 ***

Note You need to log in before you can comment on or make changes to this bug.