Bug 131411 - make bug
make bug
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-31 22:01 EDT by Shawn Wachter
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 05:01:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shawn Wachter 2004-08-31 22:01:23 EDT
Description of problem: bug reported when compiling kernel 


Version-Release number of selected component (if applicable):
fedora core 2 - not yet updated

How reproducible:
1 install fedora core 2 
2 run make xconfig
3 run make clean
4 run make bzImage
5 run make modules
-- the bug below showed up when make modules was finished

Steps to Reproduce:
1.
2.
3.
  
Actual results:
  CC [M]  net/ipv6/sysctl_net_ipv6.o
In file included from include/linux/icmpv6.h:144,
                 from include/linux/ipv6.h:175,
                 from net/ipv6/sysctl_net_ipv6.c:12:
include/linux/netdevice.h: In function `netif_tx_disable':
include/linux/netdevice.h:909: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
make[2]: *** [net/ipv6/sysctl_net_ipv6.o] Error 1
make[1]: *** [net/ipv6] Error 2
make: *** [net] Error 2
[root@localhost linux-2.6.5-1.358]#


Expected results:


Additional info:
Comment 1 Shawn Wachter 2004-08-31 22:05:59 EDT
I did not change any kernel parameters in xconfig other than those
related to the processor type and other parameters in that tree, e.g.
- memory, etc.
Comment 2 Jakub Jelinek 2004-09-01 05:01:55 EDT
This is not related to make at all, it is the compiler that is crashing,
and as the bug is not reproduceable, it is almost surely because of
flakey hardware.
I assume if you retry it will crash on some completely different
file and line.

Note You need to log in before you can comment on or make changes to this bug.