Bug 1314114 - [RFE] CephFS repair tools
[RFE] CephFS repair tools
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: CephFS (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 2.0
Assigned To: Greg Farnum
Vasu Kulkarni
Bara Ancincova
: FutureFeature
Depends On:
Blocks: 1322504
  Show dependency treegraph
 
Reported: 2016-03-02 19:09 EST by Neil Levine
Modified: 2017-07-30 11:00 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Technology Preview
Doc Text:
Documented with BZ#1314112
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 15:32:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 15145 None None None 2016-03-15 13:08 EDT

  None (edit)
Description Neil Levine 2016-03-02 19:09:28 EST
Ship the fsck-like repair tool for CephFS/MDS.
Comment 2 Ken Dreyer (Red Hat) 2016-03-04 18:31:16 EST
The specific tools here are:

/usr/bin/cephfs-data-scan
/usr/bin/cephfs-journal-tool
/usr/bin/cephfs-table-tool

In v10.0.4, these are in the "ceph-mds" package. No man pages yet.

Need positive confirmation from Product Management regarding whether we should ship them in ceph-common instead of ceph-mds (probably yes), in which case we need a PR upstream to change the RPM and Deb packaging.
Comment 3 Neil Levine 2016-03-04 21:53:14 EST
As these tools don't have to be run from the MDS server itself and can be run from any admin node, it makes sense to include them in ceph-common so let's change the packages.
Comment 4 Greg Farnum 2016-03-14 16:40:50 EDT
These are in 10.0.4, although I'm not sure about the packaging state.
Comment 5 Ken Dreyer (Red Hat) 2016-03-15 08:38:37 EDT
The tools still need to move to ceph-common.
Comment 10 Vasu Kulkarni 2016-08-02 17:41:29 EDT
Verified in 10.2.2-32.
Comment 12 errata-xmlrpc 2016-08-23 15:32:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1755

Note You need to log in before you can comment on or make changes to this bug.