Bug 1314148 - [RFE] Sort hosts alphabetically in reports(mailer)
[RFE] Sort hosts alphabetically in reports(mailer)
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Email (Show other bugs)
6.1.5
Unspecified Unspecified
unspecified Severity medium (vote)
: GA
: --
Assigned To: Katello Bug Bin
Chris Roberts
http://projects.theforeman.org/issues...
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 23:21 EST by Ranjan Kumar
Modified: 2016-07-27 07:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:02:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14173 None None None 2016-04-26 13:02 EDT

  None (edit)
Description Ranjan Kumar 2016-03-02 23:21:25 EST
1. Proposed title of this feature request  
Mailer like "Puppet Summary Report", "Satellite Host Advisory" should list host in alphabetically sorted order in reports

2. Who is the customer behind the request?  
Account: Texas A&M University - Corpus Christi (acct # 646029)  
TAM customer: no  
SRM customer: no  
Strategic: no  
  
3. What is the nature and description of the request?  
Mailer like "Puppet Summary Report", "Satellite Host Advisory" should list host in alphabetically sorted order in reports

4. Why does the customer need this? (List the business requirements here)  

When reviewing reports, locating a particular host of interest would be greatly facilitated if the list of hosts was sorted. It also looks nicer.

5. How would the customer like to achieve this? (List the functional requirements here)  

All reports in mailer should list alphabetically  sorted hosts.  

7. Is there already an existing RFE upstream or in Red Hat Bugzilla?  

No.

8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?  

This is a desire-ment, not a requirement. However, since I will be reviewing reports every day, and since the number of hosts appears to be exhibiting unbounded growth, implementation of this feature can't come too soon.

9. Is the sales team involved in this request and do they have any additional input?  

No.

10. List any affected packages or components.  

Unknown.

11. Would the customer be able to assist in testing this functionality if implemented?  

 - would you be able to assist in testing this functionality if implemented?
Yes, since I have already implemented a simple patch successfully and have tested/am running another interim patch offered by Red Hat. These two patches have made a significant improvement which is all the more useful as the number of hosts in the reports gets larger.
Comment 2 Bryan Kearney 2016-04-12 04:11:07 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14173 has been closed
-------------
Ranjan Kumar
Applied in changeset commit:cce67207deb0eb33eecd725cf89ebd6768a5dbc5.
Comment 5 Bryan Kearney 2016-07-27 07:02:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.