Bug 131415 - need createrepo, and perhaps yum-arch back
need createrepo, and perhaps yum-arch back
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Bill Nottingham
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-01 01:38 EDT by Alexandre Oliva
Modified: 2014-03-16 22:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-11 12:48:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-09-01 01:38:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
Since yum 2.1 removed yum-arch, we need something in the distro
capable of generating repositories for both yum and up2date.  Adding
createrepo is probably a must, but it would be nice to be able to
still create repositories for yum 2.0 and older versions of up2date,
so packaging yum-arch separately would be desirable.

Version-Release number of selected component (if applicable):
yum-2.1.0-1

How reproducible:
Always

Steps to Reproduce:
1.yum-arch
2.createrepo

Actual Results:  bash: yum-arch: command not found
bash: createrepo: command not found

Expected Results:  At least the latter should be available.

Additional info:
Comment 1 Barry K. Nathan 2004-09-01 07:23:44 EDT
I, for one, want the ability to run yum-arch to create
backward-compatible repos on an FC3 host. If FC3 ultimately can't do
that, then it's not a showstopper IMO, but it would be *real* nice if
it could.
Comment 2 Paul Nasrat 2004-09-01 17:16:15 EDT
Working on standalone/2.1 yum-arch with UPSTREAM development.  Have
test package locally working and yum-arch and yum-arch -d -s work fine.
Comment 3 Paul Nasrat 2004-09-01 17:17:29 EDT
createrepo should be built into rawhide
Comment 4 Paul Nasrat 2004-10-11 12:48:13 EDT
Closing for createrepo, awaiting upstream for old repo generation

Note You need to log in before you can comment on or make changes to this bug.