Bug 1314150 - Choose self-heal source as local subvolume if possible
Choose self-heal source as local subvolume if possible
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On:
Blocks: 1322521
  Show dependency treegraph
 
Reported: 2016-03-02 23:35 EST by Pranith Kumar K
Modified: 2016-06-16 09:59 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1322521 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:59:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2016-03-02 23:35:11 EST
Description of problem:
Choose self-heal source as local brick improves network bandwidth usage tremendously. This is very useful for 3-way replication with hyperconverged usecase.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2016-03-02 23:37:11 EST
REVIEW: http://review.gluster.org/13585 (cluster/afr: Choose local child as source if possible) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Vijay Bellur 2016-03-06 22:42:32 EST
REVIEW: http://review.gluster.org/13585 (cluster/afr: Choose local child as source if possible) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 3 Vijay Bellur 2016-03-11 03:57:20 EST
REVIEW: http://review.gluster.org/13585 (cluster/afr: Choose local child as source if possible) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 4 Vijay Bellur 2016-03-11 14:15:03 EST
COMMIT: http://review.gluster.org/13585 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 2807e3fc005630213ab7ad251fef13d61c07ac6b
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Wed Mar 2 22:09:44 2016 +0530

    cluster/afr: Choose local child as source if possible
    
    It is better to choose local brick as source if possible to prevent
    over the wire read thus saving on bandwidth. Also changed code to not
    attempt data-heal if 'source' is selected as arbiter.
    
    Change-Id: I9a328d0198422280b13a30ab99545370a301dfea
    BUG: 1314150
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/13585
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
    Tested-by: Krutika Dhananjay <kdhananj@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 5 Mike McCune 2016-03-28 18:23:05 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Niels de Vos 2016-06-16 09:59:06 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.