Bug 1314172 - [RHEL-7] gluster-swift: Backport fixes from swauth to gswauth
[RHEL-7] gluster-swift: Backport fixes from swauth to gswauth
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-swift (Show other bugs)
3.1
All All
unspecified Severity low
: ---
: RHGS 3.1.3
Assigned To: Prashanth Pai
surabhi
: ZStream
Depends On:
Blocks: 1299184
  Show dependency treegraph
 
Reported: 2016-03-03 02:29 EST by Prashanth Pai
Modified: 2016-06-23 01:31 EDT (History)
5 users (show)

See Also:
Fixed In Version: swiftonfile-2.3.0-0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-23 01:31:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prashanth Pai 2016-03-03 02:29:16 EST
Description of problem:

This BZ tracks effort of rebasing gswauth to latest swauth code that has many fixes. This rebase effort is limited to back-porting relevant fixes to gswauth.

Backports on review:
http://review.gluster.org/#/q/project:gluster-swift+branch:master+topic:rebase-gswauth
Comment 2 Prashanth Pai 2016-03-10 04:15:21 EST
There's a series of five upstream changes on review:
http://review.gluster.org/#/q/project:gluster-swift+branch:master+topic:rebase-gswauth
Comment 5 surabhi 2016-04-25 02:20:56 EDT
To verify this backport, took the latest build of swiftonfile with glusterfs latest build and executed the full regression suite for temp auth and gswauth , 
I see no failures or issues with the existing tests.
If in further testing find any issue with gswauth, will be raising another BZ.
Marking the BZ verified.

swiftonfile-2.3.0-2.el7rhgs.noarch
glusterfs-3.7.9-1.el7rhgs.x86_64
Comment 7 errata-xmlrpc 2016-06-23 01:31:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1289

Note You need to log in before you can comment on or make changes to this bug.