Bug 1314176 - gparted alignment error prevents overcloud deployment - VM nodes
gparted alignment error prevents overcloud deployment - VM nodes
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic (Show other bugs)
7.0 (Kilo)
x86_64 Linux
unspecified Severity urgent
: ---
: 8.0 (Liberty)
Assigned To: Lucas Alvares Gomes
Toure Dunnon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 02:49 EST by Alexandru Dan
Modified: 2016-03-16 05:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-16 05:01:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandru Dan 2016-03-03 02:49:41 EST
Description of problem:
When trying to deploy an overcloud using OSP Director 7 and vmware vms as nodes, after booting up and loading the initrd image node fails to deploy and remains in an unrecoverable state because gparted is unable to successfully create the necessary partition map.


Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1. Create a vm using vmware for OSP Director 7, install osp as shown in the documentation.
2. Prepare two vms as compute and control, using basic networking with two nics, one openstack bus and one external
3. Download RedHat OSP images and load them into glance as shown in the documentation.
4. Deploy your basic cloud using fake_pxe driver in ironic and manual startup of the vms at provisioning and deploy stage.
5. Wait for the vms to remain stuck and unrecoverable
6. Check ironic-conductor.log for errors

Actual results:
Nodes stuck in deployment

Expected results:
Nodes should partition and start writing image file to it's newly created partitions

Additional info:
gparted uses alignment to optimize partitions on the disk. Alignment should be a warning not error and should not stop the deployment.
Comment 2 Alexandru Dan 2016-03-16 05:01:35 EDT
I have moved passed it by making the disks way larger than the allocation in instackenv.json. So for a 40GB allocation I created 100GB disk file and it worked.

Note You need to log in before you can comment on or make changes to this bug.