Bug 1314181 - Wrong checkbox tooltip behavior
Wrong checkbox tooltip behavior
Status: CLOSED WONTFIX
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.2
Unspecified Unspecified
medium Severity unspecified (vote)
: ovirt-3.6.8
: ---
Assigned To: Alexander Wels
Pavel Novotny
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 03:09 EST by Idan Shaby
Modified: 2016-07-05 08:54 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 08:54:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
mgoldboi: planning_ack+
tnisan: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 54267 master ABANDONED webadmin: postpone the raise of onPropertyChanged event 2016-03-13 10:35 EDT
oVirt gerrit 54928 master MERGED webadmin: Check box tooltip 2016-03-18 11:12 EDT
oVirt gerrit 54944 ovirt-engine-3.6 MERGED webadmin: Check box tooltip 2016-03-20 05:36 EDT

  None (edit)
Description Idan Shaby 2016-03-03 03:09:07 EST
Description of problem:
EntityModel::setIsChangeable(boolean value) has a wrong behavioral pattern.

Version-Release number of selected component (if applicable):
45766401389799d916910e9e0aedc0572d279114

How reproducible:
100%


Steps to Reproduce:
1. Create a vm.
2. Go to the Disks sub tab and click new.
3. Click on "Direct LUN" and switch to VirtIO-SCSI interface.
4. Point to the "Read Only" checkbox label on the right and see the tooltip (correct behavior).
5. Disable "Enable SCSI Pass-Through", point to the "Read Only" checkbox label and see the same tooltip again (incorrect behavior since the read only checkbox is changeable).
6. Enable "Enable SCSI Pass-Through", point to the "Read Only" checkbox label and see that the tooltip is not shown (incorrect behavior since the read only checkbox is not changeable).
7. Disable "Enable SCSI Pass-Through", point to the "Read Only" checkbox label and see that the tooltip is not shown (correct).
8. Enable "Enable SCSI Pass-Through", point to the "Read Only" checkbox label and see that the tooltip is shown (correct).
9. Disable "Enable SCSI Pass-Through", point to the "Read Only" checkbox label and see that the tooltip is shown (incorrect).
10. Enable it again and see that this behavior repeats itself over and over again: incorrect, correct, correct, incorrect, incorrect, correct, correct, incorrect, incorrect, correct...

Actual results:
Wrong behavior

Expected results:
Consistent and correct behavior.

Additional info:
Also happens when using EntityModel::setIsChangeable(boolean value, String reason).
Comment 1 Idan Shaby 2016-03-13 10:40:31 EDT
Since this bug still occurs, and since patch [1] was rejected in upstream, I am moving it back to "New".

[1] For future reference:
https://gerrit.ovirt.org/#/c/54267/ - webadmin: postpone the raise of onPropertyChanged event
Comment 2 Oved Ourfali 2016-03-16 03:32:28 EDT
Idan - will you be looking at it, or shall I assign someone from the UX team?
Comment 3 Idan Shaby 2016-03-16 04:03:40 EDT
No, there was a misunderstanding and I was about to reset it the assignee again.
Thanks
Comment 4 Pavel Novotny 2016-05-11 13:19:16 EDT
FailedQA in rhevm-webadmin-portal-3.6.6.2-0.1.el6 (build 3.6.6-3).

Exactly following steps to reproduce from comment 0 and the tooltip behavior is still the same as is described there.
Comment 5 Red Hat Bugzilla Rules Engine 2016-05-11 13:19:23 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 6 Alexander Wels 2016-05-13 11:12:47 EDT
So I reverified this works on master. I also verified the code that fixes it was back ported to the 3.6 branch, and the 3.6.6 tag. Same for down stream. All the code is identical, however it doesn't work for 3.6.6 while its fine on master.

Note You need to log in before you can comment on or make changes to this bug.