Bug 1314204 - nfs-ganesha setup fails on fedora
nfs-ganesha setup fails on fedora
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: common-ha (Show other bugs)
3.7.9
All All
unspecified Severity high
: ---
: ---
Assigned To: Soumya Koduri
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 03:37 EST by Soumya Koduri
Modified: 2016-06-16 09:59 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:59:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Soumya Koduri 2016-03-03 03:37:56 EST
Description of problem:

nfs-ganesha setup fails on fedora machines (at least f22, f23) since pcs cluster setup command requires '--name' as a mandatory option.
Comment 1 Vijay Bellur 2016-03-03 03:59:10 EST
REVIEW: http://review.gluster.org/13590 (nfs-ganesha: pcs cluster setup needs '--name' option) posted (#1) for review on release-3.7 by soumya k (skoduri@redhat.com)
Comment 2 Vijay Bellur 2016-03-03 04:14:34 EST
REVIEW: http://review.gluster.org/13590 (nfs-ganesha: pcs cluster setup needs '--name' option) posted (#2) for review on release-3.7 by soumya k (skoduri@redhat.com)
Comment 3 Vijay Bellur 2016-03-03 21:11:21 EST
COMMIT: http://review.gluster.org/13590 committed in release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 812e7321d3c56d329526628fe96a8f6fabea75ca
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Thu Mar 3 14:08:39 2016 +0530

    nfs-ganesha: pcs cluster setup needs '--name' option
    
    Even on fedora machines (on f22, f23), pcs cluster setup CLI
    expects '--name' to be provided. This patch addresses the same.
    
    Change-Id: Id33c8bbdc33955dd54729b10c720f4fa646f7e8c
    BUG: 1314204
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/13590
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: jiffin tony Thottan <jthottan@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 4 Vijay Bellur 2016-03-14 07:45:51 EDT
REVIEW: http://review.gluster.org/13727 (nfs-ganesha: pcs cluster setup needs '--name' option) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 5 Vijay Bellur 2016-03-15 03:25:44 EDT
COMMIT: http://review.gluster.org/13727 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit f032bc6caedd0a53e79888e57c886ba3699d2396
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Thu Mar 3 14:08:39 2016 +0530

    nfs-ganesha: pcs cluster setup needs '--name' option
    
    Even on fedora machines (on f22, f23), pcs cluster setup CLI
    expects '--name' to be provided. This patch addresses the same.
    
    BUG: 1314204
    Change-Id: If23851bfd7fe2f1c200731d66dcb3e744390ff83
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/13590
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: jiffin tony Thottan <jthottan@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-on: http://review.gluster.org/13727
    Tested-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Comment 6 Kaushal 2016-04-19 03:22:29 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 7 Niels de Vos 2016-06-16 09:59:22 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.