Bug 1314205 - "WARNING" info is error when refresh interval below 60s
"WARNING" info is error when refresh interval below 60s
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-who (Show other bugs)
6.8
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Chris Snyder
Eko
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 03:41 EST by Liushihui
Modified: 2017-03-21 06:29 EDT (History)
3 users (show)

See Also:
Fixed In Version: virt-who-0.18-1.el6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-21 06:29:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liushihui 2016-03-03 03:41:29 EST
Description of problem:
When run virt-who with refresh interval below to 60s at CLI mode, it will show a ambiguous warning info

Version-Release number of selected component (if applicable):
virt-who-0.16-5.el6.noarch
subscription-manager-1.16.8-3.el6.x86_64
python-rhsm-1.16.6-1.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Register system to satellite6.
2. Run virt-who with refresh interval 3s at CLI mode.
[root@sgi-xe270-01 ~]# virt-who --hyperv --hyperv-owner=xxxxxx --hyperv-env=xxxxx --hyperv-server=10.73.5.227 --hyperv-username=administrator --hyperv-password=Welcome1 -i 3
2016-03-03 03:33:10,240 WARNING: Interval value may not be set below the default of 60 seconds. Will use default value.

Actual results:
It will show warning info as the following:
WARNING: Interval value may not be set below the default of 60 seconds. Will use default value.

Expected results:
It should throw warning info as the following:
WARNING: Interval value maybe set below the default of 60 seconds. Will use default value.

Additional info:
Comment 1 Radek Novacek 2016-03-10 10:28:34 EST
"WARNING: Interval value maybe set below the default of 60 seconds. Will use default value." - this is also a bit confusing.

What about this wording:

WARNING: Interval value can't be lower than 60 seconds. Default value of 60 seconds will be used.
Comment 2 Radek Novacek 2016-03-10 10:29:08 EST
Nevertheless, this is very minor issue, let's move it to 6.9.
Comment 4 Radek Novacek 2016-10-13 04:15:50 EDT
Fixed in virt-who-0.18-1.el6.
Comment 6 Eko 2016-12-06 21:39:57 EST
verified in virt-who-0.18-1.el6.

when interval < 60s, it will show:
[virtwho.init WARNING] MainProcess(30487):MainThread @parser.py:parseOptions:279 - Interval value can't be lower than 60 seconds. Default value of 60 seconds will be used.
Comment 8 errata-xmlrpc 2017-03-21 06:29:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0675.html

Note You need to log in before you can comment on or make changes to this bug.