Bug 131426 - system-config-* tools ignores preferred applications settings
Summary: system-config-* tools ignores preferred applications settings
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution   
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact: Bill Nottingham
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-01 11:15 UTC by drago01
Modified: 2014-03-17 02:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-26 20:23:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description drago01 2004-09-01 11:15:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7)
Gecko/20040808 Firefox/0.9.3

Description of problem:
I installed firefox form Fedora Extras and set it as default in
preferd applications.
When i press help in a system-config-* tool it starts mozilla. I tried
to set epiphany as default but the still start mozilla.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. open system-config-<whateveryouwant>
2. press help
    

Actual Results:  it ignores the  preferred applications settings.

Expected Results:  it should use the browser which is set as start in
 preferred applications.

Comment 1 Warren Togami 2004-09-01 11:34:36 UTC
Should be an easy fix.  Please remind me early next week to deal with
this.

Comment 2 drago01 2004-09-06 07:41:38 UTC
its next week now (monday) ;)

Comment 3 Warren Togami 2004-09-26 10:08:09 UTC
Can you be more specific about which applications exhibit this
problem?  I just tried system-config-network, and Help -> Contents
launched my Preferred Browser firefox.

Well, the Preferred Browser of the root user, since the tool is
running as root through the usermode helper thing.

Comment 4 drago01 2004-09-26 10:30:43 UTC
yes it runs the preferred browser of the root user but it should
launch the preferred browser of the user which uses the tool trought
userhelper.
even if root has the same browser it can have different settings/theme
whatever wich is anoying.


Comment 5 Warren Togami 2004-09-26 20:23:54 UTC
Sorry, there is no clean way of doing this.


Note You need to log in before you can comment on or make changes to this bug.