Bug 1314266 - Unable to log in with valid credentials
Summary: Unable to log in with valid credentials
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: core
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: gowtham
QA Contact: Daniel Horák
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-03 10:12 UTC by Daniel Horák
Modified: 2016-08-23 19:47 UTC (History)
3 users (show)

Fixed In Version: rhscon-ceph-0.0.23-1.el7scon.x86_64, rhscon-core-0.0.24-1.el7scon.x86_64, rhscon-ui-0.0.39-1.el7scon.noarch
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:47:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Daniel Horák 2016-03-03 10:12:47 UTC
Description of problem:
  Sometimes it is not possible to log in to web UI or API with valid credentials.

  Usually it works properly for some time, and then suddenly it is not possible to log in.


Version-Release number of selected component (if applicable):
  rhscon-ceph-0.0.6-10.el7.x86_64
  rhscon-core-0.0.8-10.el7.x86_64
  rhscon-ui-0.0.19-1.el7.noarch


How reproducible:
  sometimes/occasionally

Steps to Reproduce:
1. Prepare cluster with USM server perform some usual tasks and let it run for a while.

Actual results:
  Sometime it is not possible to log in to USM.
  When I fill log in credentials and click to "Log In" button, it will show:
    Authentication Error!.
  and the response for POST request is:
    {"Error":"Closed explicitly"}

Expected results:
  It is always possible to log in with valid credentials.

Additional info:
  Related part from skyring.log:

  [negroni] Started POST /api/v1/auth/login
  2016-03-03T11:11:42.134+01:00 ERROR    auth.go:163 Login] Error saving the session for user: admin. error: Closed explicitly
  2016-03-03T11:11:42.134+01:00 ERROR    auth.go:163 Login] Error saving the session for user: admin. error: Closed explicitly
  2016-03-03T11:11:42.134+01:00 ERROR    auth.go:61 login] Unable to login User:Closed explicitly
  2016-03-03T11:11:42.134+01:00 ERROR    auth.go:61 login] Unable to login User:Closed explicitly
  [negroni] Completed 401 Unauthorized in 164.924471ms

Comment 2 Martin Bukatovic 2016-03-04 17:09:18 UTC
Additional info
===============

I just hit this issue right now. All I did with the usm was:

 * accept all nodes
 * create cluster #1, but this task failed
 * remove cluster #1
 * create cluster #2, this finished, but the task is still reported as running
 * create cluster #3 and #4 at the same time

All seemed to be ok, but after a while, I hit refresh of the task page and
it redirected me back to login page, which refused to let me in even though
I used correct credentials.

rhscon-core-0.0.8-10.el7.x86_64
rhscon-ui-0.0.19-1.el7.noarch
rhscon-ceph-0.0.6-10.el7.x86_64
rhscon-agent-0.0.3-3.el7.noarch

Comment 3 Daniel Horák 2016-07-22 08:46:34 UTC
We didn't noticed this issue for the last weeks neither during	manual or
automated testing, so closing this Bug as VERIFIED.

Last time tested on:
  USM Server (RHEL 7.2):
  ceph-ansible-1.0.5-31.el7scon.noarch
  ceph-installer-1.0.14-1.el7scon.noarch
  mongodb-2.6.5-4.1.el7.x86_64
  mongodb-server-2.6.5-4.1.el7.x86_64
  rhscon-ceph-0.0.33-1.el7scon.x86_64
  rhscon-core-0.0.34-1.el7scon.x86_64
  rhscon-core-selinux-0.0.34-1.el7scon.noarch
  rhscon-ui-0.0.48-1.el7scon.noarch

  Ceph MON (RHEL 7.2):
  calamari-server-1.4.7-1.el7cp.x86_64
  ceph-base-10.2.2-24.el7cp.x86_64
  ceph-common-10.2.2-24.el7cp.x86_64
  ceph-mon-10.2.2-24.el7cp.x86_64
  ceph-selinux-10.2.2-24.el7cp.x86_64
  libcephfs1-10.2.2-24.el7cp.x86_64
  python-cephfs-10.2.2-24.el7cp.x86_64
  rhscon-agent-0.0.15-1.el7scon.noarch
  rhscon-core-selinux-0.0.34-1.el7scon.noarch

  Ceph OSD (RHEL 7.2):
  ceph-base-10.2.2-24.el7cp.x86_64
  ceph-common-10.2.2-24.el7cp.x86_64
  ceph-osd-10.2.2-24.el7cp.x86_64
  ceph-selinux-10.2.2-24.el7cp.x86_64
  libcephfs1-10.2.2-24.el7cp.x86_64
  python-cephfs-10.2.2-24.el7cp.x86_64
  rhscon-agent-0.0.15-1.el7scon.noarch
  rhscon-core-selinux-0.0.34-1.el7scon.noarch

>> VERIFIED

Comment 5 errata-xmlrpc 2016-08-23 19:47:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.