Bug 131428 - Bad xscreensaver / vncviewer interaction
Bad xscreensaver / vncviewer interaction
Status: CLOSED DUPLICATE of bug 106552
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-01 07:23 EDT by Tim Waugh
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 12:22:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2004-09-01 07:23:09 EDT
Description of problem:
When using vncviewer in full screen mode, xscreensaver blanking the
screen is disastrous because the mouse seems to "disappear".  By that
I mean that wiggling the mouse will not unblank the screen (I have to
press a key), and once the screen is unblanked there is no mouse pointer!

Version-Release number of selected component (if applicable):
xscreensaver-4.18-1
vnc-4.0-6

How reproducible:
100%

Steps to Reproduce:
1. Run 'vncserver', either on localhost or on another machine
2. Connect to it with 'vncviewer'
3. Press F8 and enable 'Full screen'
4. Wait for xscreensaver to save screen
  
Actual results:
Cannot use mouse any more.

Expected results:
Normal mouse usage.
Comment 1 Karl Latiss 2005-04-18 20:45:54 EDT
This still happens with vnc-4.0-8 and xscreensaver-4.18-4 on FC3
Comment 2 David Masterson 2005-07-23 02:13:45 EDT
This still happens with vnc-4.1.1-10 and xscreensaver-^-4.21-4 on FC4

More than that, this happens if a screensaver activates on the vnc server side.
 I use vncviewer to connect (via SSH) to my Windows-XP system at work.  If I am
in full-screen mode *AND* the WXP screensaver activates, the mouse cursor will
disappear.  I suspect that it is still there as moving the mouse and pressing F8
causes the VNC menu to move around the screen.

I can go to another login via ALT-CTL-F2 and kill vncviewer.  This does *NOT*
bring back the mouse, though.  If I knew how, I might be able to logout using
just keystrokes (anyone know how?) and that would get the mouse back (with the X
reset).
Comment 3 Tim Waugh 2005-07-23 04:59:40 EDT
See also bug #106552.
Comment 4 Ryan Stokes 2005-08-28 20:01:10 EDT
Just found a workaround that doesn't require restarting X, if you can still use
the keyboard (or ALT-CTL-F2).  Just 'killall xscreensaver' and I hope your mouse
comes back as mine just did (FC3, xscreensaver-4.18-4, vnc-4.0-8).  This is with
the client (vncviewer-side) xscreensaver blanking (not locking), and not the
remote side (which is, incidentally, running FC3, xscreensaver-4.14-5,
vnc-server-4.0-5).

Thanks for tracking this down to xscreensaver, because, as noted in Bug #106552,
comment 5, xscreensaver-4.18+ doesn't actually blank the screen (so no clue it
was even running).  Seems like it should give the mouse back when it fails though..
Comment 5 Ryan Stokes 2005-08-28 21:19:01 EDT
Killing xscreensaver also killed X thereafter with a "Fatal server error"
("signal 11"), but I was able to reliably get my mouse back after 1) 'killall
vncviewer' and then 2) 'xscreensaver-command -activate'.  That is, start it
again so it can do whatever it does with the mouse, then it will hand it off
appropiately when deactivating (when the fullscreen vncviewer isn't running).
Comment 6 Adam Tkac 2006-08-30 10:45:15 EDT
This bug is duplicate of Bug #106552. You can find patch there
Comment 7 Ray Strode [halfline] 2007-03-28 12:22:33 EDT

*** This bug has been marked as a duplicate of 106552 ***

Note You need to log in before you can comment on or make changes to this bug.