Bug 13143 - Floopy boot instal from from hard drive fails
Floopy boot instal from from hard drive fails
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: python (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-27 22:11 EDT by Charlie Smith
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-27 22:11:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charlie Smith 2000-06-27 22:11:25 EDT
Pentium 75 - 16M memory

2 Hard drives

HD 1	1.2G	Partitions

		DOS / Windows	50M

		/		50M

		swap		100M

		/usr		500M

		/home		500M

HD 2	1.6G	Partitions

		DOS		600M

		This contains RedHat 'base' & 'RPMS' directories
		since the machine's CD-ROM is not functional

		/usr		100M

		/tmp		100M

I have tried the using the 'boot.img' file created from the
CD AND also tried the boot-RHEA-1999:044.img with and without
the updates-RHEA-1999:045.img from the website.

I get the following error in either case:

Exception Occured

Traceback (innermost last):

File "/usr/bin/anaconda.real", line 225, in ?

	intf.run(todo, test = test)

File "/tmp/lib/python1.5/site-packages/text.py", line 1000, in run

	rc = apply(step[1](), step[2])

File "/mnt/redhat/comps/install/6.1/i386/misc/src/trees/hdimage
     /usr/lib/python1.5/site-packages/textw/packages.py", line 10, in 
__call__

File "/tmp/lib/python1.5/site-packages/todo.py", line 930, in getHeaderList

	self.hdlist = self.method.readHeaders()

File "/tmp/lib/python1.5/site-packages/harddrive.py", line 46, in 
readHeaders

	return HeaderList(hl)

File "/tmp/lib/python1.5/site-packages/comps.py", line 50, in __init__

	name = h[rpm.RPMTAG_NAME]

TypeError:	unsubscripted object
Comment 1 Matt Wilson 2000-07-26 00:00:37 EDT
Looks like a bad RPM on your hard drive.  Please make sure they are all intact
(do rpm -K on them)

Note You need to log in before you can comment on or make changes to this bug.