Bug 1314302 - Export CV 'since datetime' is failed with error undefined method `iso8601'
Export CV 'since datetime' is failed with error undefined method `iso8601'
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: Chris Duryee
Katello QA List
http://projects.theforeman.org/issues...
: Triaged
Depends On: 1314299
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 06:20 EST by Jitendra Yejare
Modified: 2016-07-27 05:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:25:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Errors in backend (95.91 KB, text/plain)
2016-03-03 06:20 EST, Jitendra Yejare
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14048 None None None 2016-04-22 11:47 EDT

  None (edit)
Description Jitendra Yejare 2016-03-03 06:20:05 EST
Created attachment 1132728 [details]
Errors in backend

Description of problem:
Exporting CV with option '--since' is failed with error:
undefined method `iso8601' for "2016-03-03T01:00:00+00:00":String

Version-Release number of selected component (if applicable):
Satellite 6.2 snap 2.1 (3rd Mar 2016)

How reproducible:
Always

Steps to Reproduce:
1. Attempt to export CV since some datetime.
# hammer content-view version export --since 2016-03-03T01:00:00Z --id 4

Actual results:
1. The export throws as error:
undefined method `iso8601' for "2016-03-03T01:00:00+00:00":String
2. Also throws traces in log files are attached.
3. Export failed, no directory created in export location.

Expected results:
CV should be Exported successfully.

Additional info:
Comment 2 Bryan Kearney 2016-03-03 14:01:42 EST
Upstream bug component is Content Management
Comment 3 Bryan Kearney 2016-03-03 18:01:37 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/14048 has been closed
-------------
Chris Duryee
Applied in changeset commit:katello|08f2f8bbb2b6486a8d8cb9c25e94bdfc1638c582.
Comment 4 Jitendra Yejare 2016-03-14 06:14:50 EDT
Verified in latest Satellite 6.2 snap 3.

The Content-view version is exported as expected without any error.

Output:
# hammer content-view version export --since 2016-03-14T02:00:00Z --id 8
Warning: Option --id is deprecated. This option will be removed in Katello 2.5, Use --uuid
[.........................................................................................................................................................................................................] [100%]


Moving bug to verified.
Comment 7 errata-xmlrpc 2016-07-27 05:25:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.