Bug 1314338 - update subnet gateway cause wrong DHCP pool calculation
update subnet gateway cause wrong DHCP pool calculation
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Assaf Muller
Toni Freger
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 07:29 EST by Martin Pavlásek
Modified: 2016-06-07 19:28 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-07 19:28:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1553968 None None None 2016-03-07 05:06 EST

  None (edit)
Description Martin Pavlásek 2016-03-03 07:29:01 EST
Description of problem:
Later updated subnet gateway leads to IP address conflict with DHCP pool range.

Version-Release number of selected component (if applicable):
RHEL 7.2
python-django-horizon-8.0.1-1.el7ost.noarch
openstack-dashboard-8.0.1-1.el7ost.noarch
openstack-packstack-puppet-7.0.0-0.12.dev1699.g8f54936.el7ost.noarch
openstack-neutron-common-7.0.1-10.el7ost.noarch
openstack-neutron-ml2-7.0.1-10.el7ost.noarch
openstack-neutron-7.0.1-10.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
Log in as demo user.
1. Project - Network - Networks - Create Network
2. network "test_net", subnet "test_subnet", network address 10.0.0.0/24, IPv4, tick Disable Gateway, Create
3. click to test_net row, click to Edit Subnet for test_subnet row
4. untick Disable Gateway, gateway IP 10.0.0.1, Next, leave Allocation Pools unchanged, Save

Actual results:
Computed Allocation pools is "10.0.0.1,10.0.0.254", click to Save cause red alert:
Error: Failed to update subnet "10.0.0.0/24": Gateway ip 10.0.0.1 conflicts with allocation pool 10.0.0.1-10.0.0.254

Expected results:
it should exclude the IP of gateway from the DHCP pool, so:
10.0.0.2,10.0.0.254

Additional info:
Comment 2 Matthias Runge 2016-04-07 04:30:49 EDT
According to upstream bug, it's actually a bug in neutron.
Comment 3 Assaf Muller 2016-06-07 19:28:54 EDT
The issue is not significant enough to justify the devotion of development resources. I'd rather close the bug than keep it open without any traction for years.

Note You need to log in before you can comment on or make changes to this bug.