Bug 1314351 - Rebase etcd to v2.2.5
Rebase etcd to v2.2.5
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: etcd (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Chaloupka
atomic-bugs@redhat.com
: Extras, Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 07:40 EST by Jan Chaloupka
Modified: 2016-03-31 19:26 EDT (History)
1 user (show)

See Also:
Fixed In Version: etcd-2.2.5-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-31 19:26:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Chaloupka 2016-03-03 07:40:10 EST
etcd v2.2.5 has some bug fixes and improvements since 2.2.2

2.2.5
* etcdmain: fix proxy srv lookup
* client: do not timeout when wait is true
* etcdserver, auth: not cache a flag of auth status

2.2.4
* etcdmain: avoid wrap TLS listener so HTTP server can get TLS configuration from 

2.2.3
* etcdctl: cluster health exit with non-zero when cluster is unhealthy
* client: fix goroutine leak in unreleased context
* store: fix data race when modify event in watchHub.
* etcdmain: fix writing incomplete proxy config file
* etcdserver: always check if the data dir is writable before starting
Comment 5 errata-xmlrpc 2016-03-31 19:26:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0568.html

Note You need to log in before you can comment on or make changes to this bug.