This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1314362 - Getting 500 if job invocation validation fails
Getting 500 if job invocation validation fails
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Remote Execution (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: Marek Hulan
Lukas Pramuk
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 07:58 EST by Marek Hulan
Modified: 2016-07-27 05:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:25:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14015 None None None 2016-04-22 11:54 EDT

  None (edit)
Description Marek Hulan 2016-03-03 07:58:42 EST
When I submit new invocation without specifying search query I get 500 with validation message instead of form with error messages
Comment 1 Marek Hulan 2016-03-03 07:58:43 EST
Created from redmine issue http://projects.theforeman.org/issues/14015
Comment 2 Marek Hulan 2016-03-03 07:58:48 EST
Upstream bug assigned to mhulan@redhat.com
Comment 4 Bryan Kearney 2016-03-14 08:05:06 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14015 has been closed
-------------
Marek Hulán
Applied in changeset commit:foreman_plugin|4df85451f721b62e0ef2e5488841303be8849e30.
Comment 6 Lukas Pramuk 2016-04-29 07:13:01 EDT
VERIFIED.

@Sat6.2.0-Beta-Snap9.3
tfm-rubygem-foreman_remote_execution-0.3.0.4-1.el7sat.noarch


using manual reproducer based on description in comment #0reproducer:

1. Navigate to Monitor > Jobs - New Job (/job_invocations/new)

2. Fill in all required fields but leave Search query empty and hit Submit

3. Search query field has red border and is asking for input (instead of submitting incomplete data):
 "Must select a bookmark or enter a search query"
Comment 8 errata-xmlrpc 2016-07-27 05:25:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.