Bug 1314372 - Current Rawhide Workstation live image does not reach GDM due to mislabelled /run/systemd/inhibit and /run/user/1000
Current Rawhide Workstation live image does not reach GDM due to mislabelled ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
24
x86_64 Linux
high Severity urgent
: ---
: ---
Assigned To: Lukas Vrabec
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On: 1308771
Blocks: F24AlphaBlocker
  Show dependency treegraph
 
Reported: 2016-03-03 08:15 EST by Petr Lautrbach
Modified: 2016-05-14 01:23 EDT (History)
21 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-176.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1308771
: 1315779 1320973 (view as bug list)
Environment:
Last Closed: 2016-03-08 14:07:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Lautrbach 2016-03-03 08:15:28 EST
Currently, selinux-policy-* packages don't ship %{_sysconfdir}/selinux/%1/contexts/files/file_contexts.bin. This file is created during post install phase.

It would be useful to generate this file during build time and ship it in order to prevent cases like the one with Live workstation where selinux-policy-targeted is not installed, but only unpackaged. And since there's no .bin files,
file_contexts is parsed in selabel_open().

While it's not a fix for #1308771, it could prevent similar issues in other not-yet-discovered cases and make Live images and maybe even Atomic a little bit faster.
Comment 1 Lukas Vrabec 2016-03-03 10:07:21 EST
commit bc10e3f4a04dbf4e88c4ad8634d6137590f62f1b
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Thu Mar 3 15:18:10 2016 +0100

    Build file_contexts.bin file_context.local.bin file_context.homedir.bin during build phase. This fix issue in Fedora live images when selinux-policy-targeted is not installed but just unpackaged, since there's no .bin files, file_contexts is parsed in selabel_open(). Resolves: rhbz#1314372
Comment 2 Adam Williamson 2016-03-08 14:07:43 EST
The fix worked, lives boot OK now. Thanks.

Note You need to log in before you can comment on or make changes to this bug.