Bug 1314380 - installer failed on enabling ostree plugin with error: '/usr/bin/yum -d 0 -e 0 -y list pulp-ostree-plugins' returned 1
Summary: installer failed on enabling ostree plugin with error: '/usr/bin/yum -d 0 -e ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Packaging
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Mike McCune
QA Contact: Sachin Ghai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-03 13:26 UTC by Sachin Ghai
Modified: 2019-09-26 17:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:04:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Sachin Ghai 2016-03-03 13:26:41 UTC
Description of problem: I installed sat6.2 snap2. and enabled ostree plugin using "foreman-installer --katello-enable-ostree true". but it got failed due to below error:


~]# foreman-installer --katello-enable-ostree true
 Execution of '/usr/bin/yum -d 0 -e 0 -y list pulp-ostree-plugins' returned 1: Error: No matching Packages to list
 /Stage[main]/Pulp::Install/Package[pulp-ostree-plugins]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y list pulp-ostree-plugins' returned 1: Error: No matching Packages to list
 Execution of '/usr/bin/yum -d 0 -e 0 -y list ostree' returned 1: Error: No matching Packages to list
 /Stage[main]/Pulp::Install/Package[ostree]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y list ostree' returned 1: Error: No matching Packages to list
Installing             Done                                               [100%] [..................................................................]
  Something went wrong! Check the log for ERROR-level output
  The full log is at /var/log/foreman-installer/katello.log


# /usr/bin/yum -d 0 -e 0 -y list pulp-ostree-plugins
Error: No matching Packages to list


Version-Release number of selected component (if applicable):
sat6.2 snap2

How reproducible:
always

Steps to Reproduce:
1. enabled ostree plugin
2.
3.

Actual results:
# /usr/bin/yum -d 0 -e 0 -y list pulp-ostree-plugins
Error: No matching Packages to list

Expected results:
pulp-ostree-plugins should be available.

Additional info:

Comment 2 Partha Aji 2016-03-03 20:09:36 UTC
Sat needs ostree installed prior to running "foreman-installer --katello-enable-ostree true". 

The workaround for now is to manually enable rhel-atomic-host-rpms and install ostree before running the foreman-installer.
in other words ->
# subscription-manager repos --enable=rhel-atomic-host-rpms
# yum install ostree
# foreman-installer --katello-enable-ostree true


There are plans to not require you to do that and satellite 6 repo should have ostree rpm available in it..

Comment 4 Sachin Ghai 2016-03-05 08:02:43 UTC
As per comment2, I installed ostree package first from "rhel-atomic-host-rpms" subscription. And later ran installer with following cmd, but still getting same issue:

 ~]# foreman-installer --scenario katello --katello-enable-ostree true
 Execution of '/usr/bin/yum -d 0 -e 0 -y list pulp-ostree-plugins' returned 1: Error: No matching Packages to list
 /Stage[main]/Pulp::Install/Package[pulp-ostree-plugins]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y list pulp-ostree-plugins' returned 1: Error: No matching Packages to list
Installing             Debug: /Stage[main]/Certs::Candlepin/Exec[import c [99%] [.................................................................. ]
Installing             Done                                               [100%] [..................................................................]
  Something went wrong! Check the log for ERROR-level output
  The full log is at /var/log/foreman-installer/katello.log

Comment 5 Mike McCune 2016-03-07 06:30:38 UTC
Chris,

Can you get pulp-ostree-plugins included in the comps as well as filing the appropriate Release Engineering ticket to ensure we ship the 'ostree' package in our repositories?

Comment 9 Sachin Ghai 2016-03-15 11:03:53 UTC
Thanks Eric, Mike, Partha.

I installed/enabled ostree plugin now with sat6.2 snap3.1. Moving this to verified:



 ~]# foreman-installer --katello-enable-ostree true
Installing             Done                                               [100%] [..................................................................]
  Success!

Comment 13 errata-xmlrpc 2016-07-27 09:04:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.