Bug 1314384 - Prevent EAP6 plugin from detecting EAP7 instances
Prevent EAP6 plugin from detecting EAP7 instances
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6 (Show other bugs)
JON 3.3.5
Unspecified Unspecified
high Severity high
: DR02
: One-off release
Assigned To: Michael Burman
Filip Brychta
: Triaged
Depends On:
Blocks: 1261060 1261062 1261066 1273531 1289370 1300725 1302426 1319889 1319904 1319945
  Show dependency treegraph
 
Reported: 2016-03-03 08:32 EST by Michael Burman
Modified: 2016-09-01 05:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-01 05:03:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Burman 2016-03-03 08:32:28 EST
Description of problem: EAP6 plugin will detect and fail to add EAP7 instances. The monitoring and management of EAP7 instances will be done by separate plugin, so EAP6 should detect the case where EAP7 was incorrectly detected and ignore it.


Version-Release number of selected component (if applicable): 3.3.5 / EAP plugin pack 02


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results: EAP6-plugin adds EAP7 instance, but fails with InvalidPluginConfiguration.


Expected results: EAP6 plugin ignores detected EAP7 instances.


Additional info:
Comment 1 Michael Burman 2016-03-03 08:35:05 EST
Fixed in the master:

commit 6b04a3b3e9a1ac7ad25771d54300834e048ae986
Author: Michael Burman <miburman@redhat.com>
Date:   Thu Mar 3 15:33:58 2016 +0200

    [BZ 1314384] If EAP7 is detected, ignore it


commit f01d65c0845ff7e4ce5a3d8794e36b67fe88d2e7
Author: Michael Burman <miburman@redhat.com>
Date:   Thu Feb 11 21:11:07 2016 +0200

    [BZ 1303952] Separate EAP6 instances from EAP7 instances by using domain version (sort of like Wildfly 8 detection was done). Keep the "EAP" as SHORT_NAME since several feature detections are using EAP as magic word
Comment 2 Thomas Segismont 2016-03-04 12:27:22 EST
The commits look good to me. I'm just not sure the "if(apiVersion.startsWith("1"))" check is valid with all EAP6 versions. Can you confirm it is?
Comment 3 Michael Burman 2016-03-05 02:12:42 EST
Well, the AS7 starts at 1.0 and EAP6.4 is 1.4 (and Wildfly 8 is 2.0, Wildfly 9 is 3.0 and Wildfly 10 is 4.0, EAP7.0.0 is 4.0). I'll download the EAP6.0 to verify, but other versions do apply.
Comment 4 Thomas Segismont 2016-03-07 04:01:46 EST
Sounds good then.

Note You need to log in before you can comment on or make changes to this bug.